文章标题 poj 1837: Balance(dp)

1 篇文章 0 订阅

Balance

Description
Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2

题意:给你一个杆,杆上有C个挂砝码的钩子,其位置为【-15,15】之间,有G个砝码每个砝码的范围为【1,20】,然后要求把砝码挂满,求能使杆平衡的挂法。
分析:定义一个数组dp【i,j】,表示前i个砝码刚好为j状态时的次数。当杆放上一个砝码,状态就会改变,而这一变化可以由前i个砝码所确定的状态为基础,当放上一个砝码后,可能为平衡,左倾,右倾。当j不能为负,所以得找一个平衡点,由于15*20*20=7500,所以状态为7500时平衡,小于为左倾,大于为右倾。可得到状态转移方程 dp【i,j+c[k]*w[i]】+= dp【i-1,j】。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int c[25],w[25];
int dp[25][15005];//前i个砝码,j为平衡状态,7500为平衡,小于7500为左倾大于为右倾,次数 
int main ()
{
    int C,G;
    while (cin>>C>>G){
        for (int i=1;i<=C;i++){
            cin>>c[i];
        }
        for (int i=1;i<=G;i++){
            cin>>w[i];
        }
        memset (dp,0,sizeof (dp));
        dp[0][7500]=1;//当有0个砝码时,7500为平衡,所以此时次数为1;
        for (int i=1;i<=G;i++){
            for (int j=0;j<=15000;j++){
                for (int k=1;k<=C;k++){//遍历每个挂钩的点 
                    dp[i][j+c[k]*w[i]]+=dp[i-1][j]; 
                } 
            }
        }
        printf ("%d\n",dp[G][7500]); 
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值