文章标题 POJ 1860 : Currency Exchange(最短路--spfa)

Currency Exchange

Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

题意:有n中货币,m中货币之间的兑换,Nike有S货币的金钱V。从一中货币换到另一种的汇率是rate,每次兑换需要手续费comm,比如100美元想换成俄罗斯纸币,汇率是29.75,手续费是0.39,最后兑换得到的金钱为(100-0.39)*29.75 = 2963.3975.
现问能通过兑换货币最后回到自己的纸币时能盈利。
分析:用spfa算法找一下是否存在正环。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn=205;
int n,m,s;
double val;
int u[maxn];//起始点
int v[maxn];//终点
int nex[maxn];//下一条边
double w[maxn];//权值
double rate[maxn];//汇率
double com[maxn];//手续费
int first[maxn];//第一条边
int e;
void init(){//初始化
    memset (first,-1,sizeof (first));
    e=0;
}
void add_edge(int a,int b,double r,double c){//添加边,汇率和手续费
    v[e]=b;
    nex[e]=first[a];
    w[e]=0;
    rate[e]=r;
    com[e]=c;
    first[a]=e++;
}

int cnt[maxn];
int vis[maxn];
double dis[maxn];
int spaf(int start){
    queue <int> q;
    for (int i=0;i<n;i++) dis[i]=0; 
    memset (cnt,0,sizeof (cnt));
    memset (vis,0,sizeof (vis));
    dis[start]=val;//开始的金钱;
    vis[start]=1;//标记;
    cnt[start]++;//松弛次数 
    q.push(start);
    while (!q.empty()){
        int uu=q.front();
        q.pop();
        vis[uu]=0;
        for (int i=first[uu];i!=-1;i=nex[i]){
            int vv=v[i];
            w[i]=(dis[uu]-com[i])*rate[i]-dis[uu];
            if (dis[vv]<dis[uu]+w[i]){
                dis[vv]=dis[uu]+w[i];
                if (!vis[vv]){
                    vis[vv]=1;
                    q.push(vv);
                }
                if (++cnt[vv]>n){
                    return -1;//出现负环 
                }
            }
        }
    } 
    return 1;
}
int main ()
{
    while (scanf ("%d%d%d%lf",&n,&m,&s,&val)!=EOF){
        int a,b;
        double r,c;
        init();
        for (int i=0;i<m;i++){
            scanf ("%d%d",&a,&b);
            scanf ("%lf%lf",&r,&c);
            add_edge(a,b,r,c);
            scanf("%lf%lf",&r,&c);
            add_edge(b,a,r,c); 
        }
        if (spaf(s)==-1){
            printf ("YES\n");
        }
        else printf ("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值