HDU 1365 & ZOJ 1456 Minimum Transport Cost(记录路径Floyd)

87 篇文章 0 订阅
28 篇文章 0 订阅

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10091    Accepted Submission(s): 2749


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1142  1217  1690  2112  2722 
 

题目大意:
    有N个城市,有的城市之间有道路,每进过一个道路就要花费一定的钱,每经一个城市也需要花费一定的钱(起点终点不用),求从一点到一点的最小花费以及路径。

解题思路:
    由于是一张图多组查询很自然就想到使用Floyd算法,不过要记录路径似乎就不好写了,上网查了一下,原来Floyd算法真的可以记录路径,具体方法是设置一个path[i][j]数组表示从i到j进过的第一个点,然后在松弛的时候不断更新,这样就可以记录下路径(具体写法见代码)。

AC代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f

const int maxn=100+3;
int N,G[maxn][maxn],path[maxn][maxn],tax[maxn];

void Floyd()
{
    for(int k=0;k<N;++k)
        for(int i=0;i<N;++i)
            for(int j=0;j<N;++j)
                if(G[i][k]+G[k][j]+tax[k]<G[i][j])//如果能够松弛则松弛
                {
                    G[i][j]=G[i][k]+G[k][j]+tax[k];
                    path[i][j]=path[i][k];
                }
                else if(G[i][k]+G[k][j]+tax[k]==G[i][j]&&path[i][k]<path[i][j])//如果距离相等但字典序更小也松弛
                    path[i][j]=path[i][k];//path[i][j]表示i到j进过的第一个点
}

int main()
{
    while(~scanf("%d",&N)&&N)
    {
        for(int i=0;i<N;++i)
            for(int j=0;j<N;++j)
            {
                scanf("%d",&G[i][j]);
                if(G[i][j]==-1)
                    G[i][j]=INF;
                path[i][j]=j;
            }
        for(int i=0;i<N;++i)
            scanf("%d",&tax[i]);
        Floyd();
        int s,t;
        while(~scanf("%d%d",&s,&t)&&!(s==-1&&t==-1))
        {
            printf("From %d to %d :\nPath: %d",s,t,s);
            int tmp=s-1;
            while(tmp!=t-1)
            {
                printf("-->%d",path[tmp][t-1]+1);
                tmp=path[tmp][t-1];
            }
            printf("\nTotal cost : %d\n\n",G[s-1][t-1]);
        }
    }
    
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值