HDU 1003 Max Sum (经典dp入门题)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 235898    Accepted Submission(s): 55672


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 


题解:一个经典的dp入门题,设dp[I]为取到第i位时子串的最大和,然后递推dp[i]=max(dp[i-1]+a[i],a[i]),这里注意数据的初始化,一定要初始化左右标记为1,max为-inf或dp[1],否则对于一个负数串就会出现错误

代码如下:
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int dp[100005];
int beg[100005];


int main()
{
    int T;
    cin>>T;
    for(int j=1;j<=T;j++)
    {
        fill(dp,dp+100001,-100000005);
        int n;
        cin>>n;
        scanf("%d",&dp[1]);;
        beg[1]=1;
        for(int i=2;i<=n;i++)
        {
            int a;
            scanf("%d",&a);
            if(dp[i-1]>=0){
                beg[i]=beg[i-1];
                dp[i]=dp[i-1]+a;
            }
            else{
                dp[i]=a;
                beg[i]=i;
            }
        }
        int ans=dp[1];
        int l=1,r=1;
        for(int i=1;i<=n;i++)
        {
            if(dp[i]>ans)
            {
                ans=dp[i];
                l=beg[i];
                r=i;
            }
        }
        printf("Case %d:\n",j);
        printf("%d %d %d\n",ans,l,r);
        if(j!=T)
            printf("\n");
    }
    //cout << "Hello world!" << endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值