HDU2273-The buses

216 篇文章 0 订阅

The buses

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                        Total Submission(s): 677    Accepted Submission(s): 343


Problem Description
Garfield applied for a good job recently, and he will go to work soon by car or bus. Garfield is very broody, sometimes when he sits on the bus to wait for the traffic light, he thinks about how long all the buses pass the traffic turning. 
  Now we describe the situations when the buses stop at the traffic turning to wait for the traffic light. First the light is red, then when the light changes to green, all the buses are prepared to move. And at the beginning, all the buses are close to each other without any space, and they have different lengths and the largest speeds. We assume any car can reach the speed that isn’t beyond the maximal speed at once.
  Now Garfield wants you to calculate minimal time all the buses pass the turning.

 

Input
There are many cases. For each case, there is two intergers N(1<=N<=100), representing the number of the buses. There are two interges in the following N lines, for the length Li(meter, 1<=Li<=10) and the maximal speed Si(meter/second, 1<=Si<=10) of the i-th bus.
 

Output
For each case, print the result obtaining two digits after the decimal point.
 

Sample Input
  
  
2 1 2 2 3
 

Sample Output
  
  
1.50
 

Source
 

题意:n组数据,下面n行表示车长度,车速度,问通过路口需要的最短时间

解题思路:所有车长/最小车速

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>

using namespace std;

int n;

int main()
{
    while(~scanf("%d",&n))
    {
        int a[200],b[200];
        for(int i=0; i<n; i++)
            scanf("%d%d",&a[i],&b[i]);
        int minn=*min_element(b,b+n);
        int sum=0;
        for(int i=0; i<n; i++)sum+=a[i];
        printf("%.2lf\n",1.0*sum/minn);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值