poj 3277(线段树+离散化)

City Horizon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18646 Accepted: 5145

Description

Farmer John has taken his cows on a trip to the city! As the sun sets, the cows gaze at the city horizon and observe the beautiful silhouettes formed by the rectangular buildings.

The entire horizon is represented by a number line with N (1 ≤ N ≤ 40,000) buildings. Building i's silhouette has a base that spans locations Ai through Bi along the horizon (1 ≤ Ai < Bi ≤ 1,000,000,000) and has height Hi (1 ≤ Hi ≤ 1,000,000,000). Determine the area, in square units, of the aggregate silhouette formed by all N buildings.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Input line  i+1 describes building  i with three space-separated integers:  AiBi, and  Hi

Output

Line 1: The total area, in square units, of the silhouettes formed by all  N buildings

Sample Input

4
2 5 1
9 10 4
6 8 2
4 6 3

Sample Output

16

Hint

The first building overlaps with the fourth building for an area of 1 square unit, so the total area is just 3*1 + 1*4 + 2*2 + 2*3 - 1 = 16.

//坐标 x离散化  离散后求相邻两点的最大值h 接着对应原始的x坐标求面积 这里需要注意离散化卡map 所以可以利用二分查找  还有由于更新会导致左右两个坐标都被覆盖,所以离散化时可以 1 3 5 7。。。这样离散 每次求2 4 6 8的值即可 

#include <algorithm>
#include <iostream>
#include <map>
#include <set>
#include <cstring>
#include <cstdio>
using namespace std;
#define ll long long
const int N=1e6+5;
int n;
int l[N],r[N],h[N];
set<int>s;
set<int>::iterator it;
int Map[2*N];
ll ans;

void init()
{
    s.clear();
    memset(Map,0,sizeof(Map));
    memset(l,0,sizeof(l));
    memset(r,0,sizeof(r));
    memset(h,0,sizeof(h));
}

struct Node
{
    int l,r;
    int Ma;
}seg[4*N];

void PushDown(int rt)
{
    int t=seg[rt].Ma;
    if(t>seg[2*rt].Ma)seg[2*rt].Ma=t;
    if(t>seg[2*rt+1].Ma)seg[2*rt+1].Ma=t;
}

void Build(int rt,int l,int r)
{
    seg[rt].l=l,seg[rt].r=r;
    seg[rt].Ma=0;
    if(l!=r)
    {
        Build(2*rt,l,(l+r)/2);
        Build(2*rt+1,(l+r)/2+1,r);
    }
}

void Update(int rt,int l,int r,int val)
{
    if(seg[rt].l==l&&seg[rt].r==r)
    {
        if(val>seg[rt].Ma)seg[rt].Ma=val;
        return;
    }
    PushDown(rt);
    int mid=(seg[rt].l+seg[rt].r)/2;
    if(r<=mid)Update(2*rt,l,r,val);
    else if(l>mid)Update(2*rt+1,l,r,val);
    else
    {
        Update(2*rt,l,mid,val);
        Update(2*rt+1,mid+1,r,val);
    }
}

void solve(int rt,int l,int r)
{
    PushDown(rt);
    if(l==r)
    {
        if(r%2==0)
        {
            int mi=seg[rt].r;
            ans+=(ll)(seg[rt].Ma)*(Map[mi+1]-Map[mi-1]);
        }
        return;
    }
    else
    {
        int mid=(l+r)/2;
        solve(2*rt,l,mid);
        solve(2*rt+1,mid+1,r);
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",l+i,r+i,h+i);
            s.insert(l[i]),s.insert(r[i]);
        }
        int cnt=1;
        for(it=s.begin();it!=s.end();it++) //二分查找时由于是1 3 5  所以需要把 2 4 6补上
        {
            int t=*it;
          //  cout<<t<<endl;
            Map[cnt]=t;
          //  cout<<cnt<<endl;
            Map[cnt+1]=t;
            cnt+=2;
        }
        cnt-=2;
        Build(1,1,cnt);
        for(int i=1;i<=n;i++)
        {
            int L=l[i],R=r[i];
            L=lower_bound(Map+1,Map+cnt+1,L)-Map;
            R=lower_bound(Map+1,Map+cnt+1,R)-Map;
            Update(1,L,R,h[i]);
        }
        ans=0;
        solve(1,1,cnt);
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值