HDU 1041.Computer Transformation【递推+高精】【12月27】

Computer Transformation

Problem Description
A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on. 

How many pairs of consequitive zeroes will appear in the sequence after n steps? 
 

Input
Every input line contains one natural number n (0 < n ≤1000).
 

Output
For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.
 

Sample Input
  
  
2 3
 

Sample Output
  
  
1 1
直接上代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
using namespace std;
int main()
{
    long long  f[1010][100]={0}, a[1010];
    //n为奇数 f[n] = f[n-1]*2 + 1;
    //n为偶数 f[n] = f[n-1]*2 -1;
    int n;
    bool flag = true;
    f[1][0] = 0;
    a[1] = 1;
    for(int i = 2;i < 1010; ++i)
    {
        a[i] = a[i-1];
        for(int j = 0;j < a[i]; ++j)    f[i][j] = f[i-1][j]*2;
        for(int j = 0;j < a[i]; ++j)
        {
            f[i][j+1] += f[i][j]/10000;
            f[i][j] %= 10000;
        }
        if(flag) f[i][0] +=1;
        else f[i][0] -= 1;
        int k = 0;
        while(f[i][k] < 0)
        {
            f[i][k] += 10000;
            f[i][k+1] -= 1;
            k++;
        }
        if(f[i][a[i]] > 0) a[i]++;
        flag = !flag;
    }
    while(scanf("%d", &n) != EOF)
    {
        cout <<f[n][a[n]-1];
        for(int i = a[n]-2;i >= 0; --i)
            printf("%04d",f[n][i]);
        cout << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值