HDU 5842.Lweb and String【最长上升子序列】【思路题】【8月20】

Lweb and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 596    Accepted Submission(s): 363


Problem Description
Lweb has a string  S .

Oneday, he decided to transform this string to a new sequence. 

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

You need transform every letter in this string to a new number.

A  is the set of letters of  S B  is the set of natural numbers. 

Every injection  f:AB  can be treat as an legal transformation. 

For example, a String “aabc”,  A={a,b,c} , and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

Now help Lweb, find the longest LIS which you can obtain from  S .

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
 

Input
The first line of the input contains the only integer  T,(1T20) .

Then  T  lines follow, the i-th line contains a string  S  only containing the lowercase letters, the length of  S  will not exceed  105 .
 

Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
 

Sample Input
  
  
2 aabcc acdeaa
 

Sample Output
  
  
Case #1: 3 Case #2: 4
 
题意:字母对应数字球最长上升子序列
思路:没有规定字母对应的数字,那么只需求有多少种字母就可以了
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int T, ans[30], kase =1;
char s[100005];
int main()
{
    scanf("%d", &T);
    while(T--)
    {
        memset(ans, 0, sizeof(ans));
        scanf("%s", s);
        int cnt = 0, l = strlen(s);
        for(int i = 0; i < l; ++i)
        {
            ans[s[i]-'a']++;
            if(ans[s[i]-'a'] == 1) cnt++;
        }
        printf("Case #%d: %d\n", kase++, cnt);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值