1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given “Is PAT&TAP symmetric?”, the longest symmetric sub-string is “s PAT&TAP s”, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.
Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11


动态规划:最长回文子串
dp[i][j]=1,即i-j为回文串。
动态规划函数如下,ans记录长度。:

for(int l=3;l<=len;l++){
        for(int i=0;i+l-1<len;i++){
            int j=i+l-1;
            if(s[i]==s[j]&&dp[i+1][j-1]){
                dp[i][j]=1;
                ans=l;
            }
        }
    }

#include<iostream>
#include<string>
using namespace std;
#define maxn 1010
int dp[maxn][maxn]={0};
int main(){
    string s;
    int ans=1;
    getline(cin,s);
    int len=s.size();
    for(int i=0;i<len;i++){
        dp[i][i]=1;
        if(i<len-1){
            if(s[i]==s[i+1]){
                dp[i][i+1]=1;
                ans=2;
            }
        }
    }
    for(int l=3;l<=len;l++){
        for(int i=0;i+l-1<len;i++){
            int j=i+l-1;
            if(s[i]==s[j]&&dp[i+1][j-1]){
                dp[i][j]=1;
                ans=l;
            }
        }
    }
    printf("%d\n",ans); 
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值