[字符串]PAT1040 Longest Symmetric String

1040. Longest Symmetric String (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

题意:找出字符串中的最长的回文子串的长度。

最基础的字符串处理题目,没有什么难度。

#include<iostream>
#include<string>

using namespace std;

bool Symmetric(string &str,int s,int len)
{
    int i,j,k;
    for(i=s;i<len/2+s;i++)
    {
        if(str[i]!=str[s+len-(i-s)-1]) return false;
    }
    return true;
}


int main()
{
    string str;
    getline(cin,str);
    int maxlen=1;
    int i,j,k;
    for(i=0;i<str.size();i++)
    {
        for(j=1;j<=str.size()-i;j++)
        {
            if(Symmetric(str,i,j)&&j>maxlen) maxlen=j;
        }
    }
    cout<<maxlen<<endl;
    return 0;
}



  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值