hdu 1394 Minimum Inversion Number(树状数组求逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16878    Accepted Submission(s): 10255


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
题目:每次可以把前k个数字按照原来顺序放到最后面,问最小的逆序数是多少?

思路:朴素算法求原序列逆序数肯定不行,n=5000承受不了n²,所以我们考虑用线段树或者树状数组来求原序列的逆序数

由于序列是从小到大的,我们可以从n到1进行枚举,每次枚举到a[i],就把在树状数组中的1~a[i-1]的数加起来(有这个数则为1,没有则为0,这样和就是存在的数的个数,并且都小于a[i]),然后更新a[i]即可。

求出原序列的逆序数后,我们再从1到n扫一遍,因为我们可以很容易得到把序列第一个数放到最后一个数的公式

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 5050
int a[N],b[N],c[N];
int n;
int lowbit(int x)
{
    return x&-x;
}
void add(int x,int v)
{
    for(int i=x; i<=n; i+=lowbit(i))
        c[i]+=v;
}
int sum(int x)
{
    int ans=0;
    for(int i=x; i; i-=lowbit(i))
        ans+=c[i];
    return ans;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            a[i]++;
        }
        int cnt=0;
        for(int i=n; i>=1; i--)
        {
            cnt+=sum(a[i]-1);
            add(a[i],1);
        }
        int ans=cnt;
        for(int i=1; i<=n; i++)
        {
            cnt=cnt+n+1-2*a[i];
            ans=min(ans,cnt);
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值