hdu 4884 TIANKENG’s rice shop(模拟)

TIANKENG’s rice shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 924    Accepted Submission(s): 228


Problem Description
TIANKENG managers a pan fried rice shop. There are n kinds of fried rice numbered 1-n. TIANKENG will spend t time for once frying. Because the pan is so small, TIANKENG can fry k bowls of fried rice with same kind at most. Assuming that there are m customers coming to the shop, and we know the arriving time of each customer and the brand and number of the fried rice they need. Could you tell TIANKENG the departure time of every customer respectively? Pay attention that TIANKNEG will serve the customer who comes earlier and he will fry the rice as much as possible. Meanwhile, customers are in queue depending on their arriving time(the earlier they arrive, the more front they stand).
 

Input
The first line contains a positive integer T(T<=100), referring to T test cases.
For each test case, the first line has 4 positive integer n(1<=n<=1000), t(1<=t<=10), k(1<=k<=5), m(1<=m<=1000), then following m lines , each line has a time(the time format is hh:mm, 0<=hh<=23, 0<=mm<=59) and two positive integer id(1<=id<=n), num(1<=num<=10), which means the brand number of the fried rice and the number of the fried rice the customer needs.
Pay attention that two or more customers will not come to the shop at the same time, the arriving time of the customer will be ordered by the time(from early time to late time)
 

Output
For each test case print m lines, each line contains a time referring to the departure time of the customer. There is a blank line between two test cases.
 

Sample Input
  
  
3 2 1 4 2 08:00 1 5 09:00 2 1 2 5 4 3 08:00 1 4 08:01 2 2 08:02 2 2 2 5 4 2 08:00 1 1 08:04 1 1
 

Sample Output
  
  
08:02 09:01 08:05 08:10 08:10 08:05 08:10
思路:

注意:

5
2 5 2 3
08:00 1 7
08:01 2 3
08:03 1 3

ans:
08:20
08:30
08:35
还有注意第二天的情况,即客人到来时是23:59 可能会到第二天才走
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 2050
int num[N],last[N];
int flag[N];
int main()
{
    int T,q;
    int n,t,k,m;
    int time,id,nu;
    int sx,sy;
    scanf("%d",&T);
    for(int q=1; q<=T; q++)
    {
        scanf("%d %d %d %d",&n,&t,&k,&m);
        memset(num,0,sizeof(num));
        memset(last,0,sizeof(last));
        int now=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d:%d %d %d",&sx,&sy,&id,&nu);
            time=sx*60+sy;
            if(last[id]>=time&&num[id]>=nu)
            {
                printf("%02d:%02d\n",((last[id]+t)/60)%24,(last[id]+t)%60);
                num[id]-=nu;
                continue;
            }
            if(last[id]>=time)
                nu-=num[id];
            int x=(nu-1)/k+1;
            now=max(now,time)+x*t;
            printf("%02d:%02d\n",(now/60)%24,(now%60));
            num[id]=x*k-nu;
            last[id]=now-t;
        }
        if(q!=T) printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值