NYOJ714-Card Trick

Card Trick
时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入
245

样例输出
2 1 4 33 1 4 5 2


来源
第六届河南省程序设计大赛

 

 

题目大意是:有n张牌,找到一个顺序,使得第一次把上面一张取出放到最下面,

然后取出最上面一张是一,第i次把上面i张取出放到最下面,然后取出一张是i;

//模拟即可

#include<stdio.h>
#include<string.h>
int a[20],b[20];
void MoveBack(int n,int m)//将第一张牌移到牌堆最后
{
    int i;
 for(i=1;i<m;i++)
 {
  a[i]=a[i+1];
 }
 a[m]=n;
}
void DelTop(int m)//删除第一张牌
{
 int i;
 for(i=1;i<=m;i++)
 {
  a[i]=a[i+1];
 }
}
int main()
{
 int i,j,n,m,k,v,x,flag;
 scanf("%d",&n);
 while(n--)
 {
  scanf("%d",&m);
  for(i=1;i<=m;i++)
     a[i]=i;
  x=1;k=1;flag=m;
  while(m)
  {
     v=x;
     while(v--)
     MoveBack(a[1],m);
     b[a[1]]=k++;
     DelTop(m--);
     x++;
  }
  printf("%d",b[1]);
  for(i=2;i<=flag;i++)
   printf(" %d",b[i]);
  puts("");
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
 }
 return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

光仔December

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值