Big Number

 

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17349    Accepted Submission(s): 7775


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 


 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7  on each line.
 


 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 


 

Sample Input
  
  
2 10 20
 


 

Sample Output
  
  
7 19
 

 

这道题一开始我使用long计数,后来发现范围有限,会导致溢出,便想用字符串处理,但字符串不可以完成计算
仔细观察题目,虽然数字之间相乘或相加后溢出,但单个数字可以进行运算,因为要输出十进制的位数,所以用math.h库中的lg函数,格式是  1g10(x)。。x为double类型,注意使用类型转换,位数的初始值是1,
这样数字分别取lg再相加,强制类型转换为int就可了

 

#include<stdio.h>
#include<math.h>
int main()
{
    int nl,i;
    long  n;
    double lg_n,ndigits;
    scanf("%d",&nl);
    while(nl--)
    {
        ndigits=1;
        scanf("%ld",&n);
        for(i=1;i<=n;i++)
        {
            ndigits+=log10((double)i);

        }
        printf("%d\n",(int)ndigits);
    }
    return 0;
}

 

 

作为一个新手,不敢说是给别人指点,只是希望督促自己学会总结,如果盲目的刷题,倒不如一题不做。
如果有更好的做法,或者忽略的更重要的算法或者知识点,请毫不留情的指出!

这是AC了的代码。
 
如有问题,恳请更正,


 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值