poj 2942 Knights of the Round Table 圆桌骑士(双连通分量模板题)

Knights of the Round Table
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 9169 Accepted: 2960

Description

Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a small group of the knights isthere, while the rest are busy doing heroic deeds around the country. 

Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:
  • The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.
  • An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of votes, and the argument goes on.)
Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons). If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled. 

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ). 

The input is terminated by a block with n = m = 0 . 

Output

For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled. 

Sample Input

5 5
1 4
1 5
2 5
3 4
4 5
0 0

Sample Output

2

Hint

Huge input file, 'scanf' recommended to avoid TLE. 

搜索双连通分量。深度优先搜索过程中,用一个栈保存所有经过的节点,判断割点,碰到割点就标记当前栈顶的结点并退栈,直到当前结点停止并标记当前割点。标记过的结点处于同一个双连通分量。

交叉染色搜索奇圈。在一个节点大于2的双连通分量中,必定存在一个圈经过该连通分量的所有结点;如果这个圈是奇圈,则该连通分量内的所有的点都满足条件;若这个圈是偶圈,如果包含奇圈,则必定还有一个奇圈经过所有剩下的点。因此一个双连通分量中只要存在一个奇圈,那么该双联通分量内的所有的点都处于一个奇圈中,在题目中,即武士可以坐成一圈。根据这个性质,只需要在一个双联通分量内找奇圈即可判断该双联通分量是否满足条件。交叉染色法就是在dfs的过程中反复交换着用两种不同的颜色对点染色,若某次dfs中当前结点的子节点和当前结点同色,则找到奇圈。

参考于: http://www.cnblogs.com/wuyiqi/archive/2011/10/19/2217911.html

#include "stdio.h"
#include "string.h"

#define N 1010

int time;
int n,m;
bool map[N][N];

struct node
{
    int x,y;
    //int weight;
    bool visit;  //用来标记该边是否已经访问
    int next;
}edge[2*N*N];
int idx,head[N];

bool odd[N];
bool mark[N];  //标记点是否为当前双连通分量中的元素
int low[N],dfn[N];
int st[N*N],top;  //模拟栈
int col[N];

void Read_date();
inline int MIN(int a,int b) { return a<b?a:b; }
void Init(){ idx=0; memset(head,-1,sizeof(head)); }
void Add(int x,int y)
{
    edge[idx].x = x;
    edge[idx].y = y;
    edge[idx].visit = false;
    edge[idx].next = head[x];
    head[x] = idx++;
}

bool find(int x)   //判断当前双连通分量是否为二分图
{
    int i,y;
    for(i=head[x]; i!=-1; i=edge[i].next)
    {
        y = edge[i].y;
        if(mark[y])
        {
            if(col[y]==-1)
            {
                col[y] = !col[x];
                return find(y);
            }
            else if(col[y]==col[x])
                return false;  //不是二分图,返回false
        }
    }
    return true; //是二分图,返回true
}

void Color(int x)
{
    int i;
    memset(mark,false,sizeof(mark));
    while(1)
    {
        i = st[top];
        top--;
        mark[edge[i].x] = true;
        mark[edge[i].y] = true;
        if(edge[i].x==x) break;
    }
    memset(col,-1,sizeof(col));
    col[x] = 0;
    if(!find(x))  //双连通分量不是二分图,则这些点全部可以
    {
        for(i=1; i<=n; ++i)
        {
            if(mark[i])
                odd[i] = 1;
        }
    }
}

void DFS(int x)
{
    int i,y;
    low[x] = dfn[x] = ++time;
    for(i=head[x]; i!=-1; i=edge[i].next)
    {
        y = edge[i].y;
        if(edge[i].visit) continue;
        edge[i].visit = edge[i^1].visit = 1;
        st[++top] = i;
        if(!dfn[y])
        {
            DFS(y);
            low[x] = MIN(low[x],low[y]);
            if(low[y]>=dfn[x])   //找到割顶或者为根节点
                Color(x);
        }
        else
            low[x] = MIN(low[x],dfn[y]);
    }
}

int Solve()
{
    int i;
    int num=0;
    time = 0;
    top = 0;
    memset(dfn,0,sizeof(dfn));
    memset(odd,false,sizeof(odd));
    for(i=1; i<=n; ++i)
    {
        if(!dfn[i])  //表示点i未被访问过
            DFS(i); //以i为根节点找双连通分量
    }
    for(i=1; i<=n; ++i)
    {
        if(!odd[i])
            num++;
    }
    return num;
}

int main()
{
    while(scanf("%d%d",&n,&m),n||m)
    {
        Read_date();
        printf("%d\n",Solve());
    }
    return 0;
}

void Read_date()
{
    int i,j;
    int x,y;
    memset(map,true,sizeof(map));
    while(m--)
    {
        scanf("%d %d",&x,&y);
        map[x][y] = map[y][x] = false;
    }
    Init();
    for(i=1; i<=n; ++i)
    {
        for(j=i+1; j<=n; ++j)
        {
            if(map[i][j])
            {
                Add(i,j);
                Add(j,i);
            }
        }
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值