1065. A+B and C (64bit) (20)
时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.
Input Specification:
The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:3 1 2 3 2 3 4 9223372036854775807 -9223372036854775808 0Sample Output:
Case #1: false Case #2: true Case #3: false
a 参考了http://tech-wonderland.net/blog/pat-1065-ab-and-c-64bit.html
//一个是LLONG_MAX #include <climits>
#include<iostream>
#include<string>
#include<climits>
using namespace std;
int main()
{ int n,m;
long long int a,b,c;
while(cin>>n){
m=n;
//cout<<LLONG_MAX;
while(m--){
cin>>a>>b>>c;
if(a>LLONG_MAX-b&&a>0&&b>0){//a+b超过
cout<<"Case #"<<n-m<<": true"<<endl;
}else if(a<LLONG_MIN-b&&a<0&&b<0){
cout<<"Case #"<<n-m<<": false"<<endl;
}else if(a+b>c){
cout<<"Case #"<<n-m<<": true"<<endl;
}else {
cout<<"Case #"<<n-m<<": false"<<endl;
}
}
}
return 0;
}