POJ 1579 Function Run Fun 记忆化搜索

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

按照题目要求去递归搜索   因为产生了大量的子递归(重复)  所以肯定会超时 
所以需要用到 记忆化搜索 把每个递归的a,b,c值保存起来  下次即可直接使用      
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int q[50][50][50];             //记忆化搜索 
int recursive(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
        return 1;
    if(q[a][b][c]!=0)
        return q[a][b][c];        //直接使用
    else if(a>20||b>20||c>20)
        return recursive(20,20,20);
    else if(a<b&&b<c)
        return q[a][b][c]=recursive(a,b,c-1)+recursive(a,b-1,c-1)-recursive(a,b-1,c);        // 保存
    else
        return q[a][b][c]=recursive(a-1,b,c)+recursive(a-1,b-1,c)+recursive(a-1,b,c-1)-recursive(a-1,b-1,c-1); //保存
}
int main()
{
    int a,b,c,s;
    while(cin>>a>>b>>c)
    {
        memset(q,0,sizeof(q));
        if(a==-1&&b==-1&&c==-1)
            break;
        s=recursive(a,b,c);
        printf("w(%d, %d, %d) = %d\n",a,b,c,s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值