HDU 5024 (广州网络赛) Wang Xifeng's Little Plot 记忆化搜索+枚举

Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao's wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
 

Input
The map of Da Guan Yuan is represented by a matrix of characters '.' and '#'. A '.' stands for a part of road, and a '#' stands for other things which one cannot step onto. When standing on a '.', one can go to adjacent '.'s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.
 

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai's rooms. A road's length is the number of '.'s it includes. It's guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
  
  
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
  
  
3 4 3 5 .表示路 #表示墙 求一段最长的路 这条路最多有一个90度的拐弯 代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#define mm 105
using namespace std;
char map[mm][mm];
int fx[8]={0,0,1,-1,1,-1,1,-1};
int fy[8]={1,-1,0,0,1,-1,-1,1};
int mem[mm][mm][8];     //记忆化搜索
int dfs(int x,int y,int dir)
{
    if(mem[x][y][dir]!=-1)
        return mem[x][y][dir];
    if(map[x+fx[dir]][y+fy[dir]]=='.')
        return mem[x][y][dir]=1+dfs(x+fx[dir],y+fy[dir],dir);   
    else
        return mem[x][y][dir]=1;
}
int main()
{
    int m,n,i,j,maxx;
    while(~scanf("%d",&m))
    {
        memset(map,0,sizeof(map));
        memset(mem,-1,sizeof(mem));
        maxx=0;
        if(m==0)
            break;
        for(i=1;i<=m;i++)
            scanf("%s",map[i]+1);
        for(i=1;i<=m;i++)
            for(j=1;j<=m;j++)
        {
            if(map[i][j]=='.')
               {
                   maxx=max(maxx,dfs(i,j,0)+dfs(i,j,2)-1);      //枚举所有可能的90度拐弯 共八种 
                   maxx=max(maxx,dfs(i,j,0)+dfs(i,j,3)-1);      //最长路等于两边相加 再减去一个多加的起点
                   maxx=max(maxx,dfs(i,j,1)+dfs(i,j,2)-1);
                   maxx=max(maxx,dfs(i,j,1)+dfs(i,j,3)-1);
                   maxx=max(maxx,dfs(i,j,4)+dfs(i,j,7)-1);
                   maxx=max(maxx,dfs(i,j,4)+dfs(i,j,6)-1);
                   maxx=max(maxx,dfs(i,j,5)+dfs(i,j,6)-1);
                   maxx=max(maxx,dfs(i,j,5)+dfs(i,j,7)-1);
               }
        }
        cout<<maxx<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值