hdu5423 Rikka with Tree

Rikka with Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 885    Accepted Submission(s): 405


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For a tree  T , let  F(T,i)  be the distance between vertice 1 and vertice  i .(The length of each edge is 1). 

Two trees  A  and  B  are similiar if and only if the have same number of vertices and for each  i  meet  F(A,i)=F(B,i)

Two trees  A  and  B  are different if and only if they have different numbers of vertices or there exist an number  i  which vertice  i  have different fathers in tree  A  and tree  B  when vertice 1 is root.

Tree  A  is special if and only if there doesn't exist an tree  B  which  A  and  B  are different and  A  and  B  are similiar.

Now he wants to know if a tree is special.

It is too difficult for Rikka. Can you help her?
 

Input
There are no more than 100 testcases. 

For each testcase, the first line contains a number  n(1n1000) .

Then  n1  lines follow. Each line contains two numbers  u,v(1u,vn)  , which means there is an edge between  u  and  v .
 

Output
For each testcase, if the tree is special print "YES" , otherwise print "NO".
 

Sample Input
  
  
3 1 2 2 3 4 1 2 2 3 1 4
 

Sample Output
  
  
YES NO
Hint
For the second testcase, this tree is similiar with the given tree: 4 1 2 1 4 3 4
 

Source
都是学长讲的:

题意:如果一个树是special的话,那么 不可能存在另外一个树使得它们两个即similiar又different!
          similiar:两棵树的各节点到根节点的距离都相同 && 两棵树又相同的节点数;
          different:两棵树的某点的父节点是不同的         or    两棵树又不同数量的结点;

分析:根据题意可得,两棵树绝对是具有相同的结点数;
          又两种情况,一种是这棵树是条链--->一定是special;
                              另一种是这可数如果深度为一------->一定是speci;
         综合两种情况:第一种情况后接第二种情况的话,那么也是special的(结合样例)

思路:就是搜索是否存在一个有相同深度的结点,并且下一个深度是没有结点存在的话就是specia;

代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<stack>
#include<iostream>
#include<cmath>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int inf=1e9-1;
const int maxn=1010;

int G[maxn][maxn],dis[maxn],dep[maxn];

int n;
void dfs(int x,int num)
{
    dis[x]=num;
    for(int i=1; i<=n; i++)
    {
        if(G[x][i]&&!dis[i])
            dfs(i,num+1);
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        int u,v;
        mem(G,0),mem(dis,0),mem(dep,0);
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&u,&v);
            G[u][v]=G[v][u]=1;
        }

        dfs(1,1);//dfs各节点的深度;
        for(int i=1; i<=n; i++)
            dep[dis[i]]++;

        //只有当各深度得节点数均为1或者只有最后一个深度的节点数不为1时;
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            if(dep[i]==1)
                ans++;
            else
            {
                if(dep[i+1]==0)
                    ans=n;
                break;
            }
        }

        if(ans==n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


         

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值