BestCoder Round #53 (div.2) HDOJ5423 Rikka with Tree(bfs)

Rikka with Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 312    Accepted Submission(s): 156


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For a tree  T , let  F(T,i)  be the distance between vertice 1 and vertice  i .(The length of each edge is 1). 

Two trees  A  and  B  are similiar if and only if the have same number of vertices and for each  i  meet  F(A,i)=F(B,i)

Two trees  A  and  B  are different if and only if they have different numbers of vertices or there exist an number  i  which vertice  i  have different fathers in tree  A  and tree B  when vertice 1 is root.

Tree  A  is special if and only if there doesn't exist an tree  B  which  A  and  B  are different and  A  and  B  are similiar.

Now he wants to know if a tree is special.

It is too difficult for Rikka. Can you help her?
 

Input
There are no more than 100 testcases. 

For each testcase, the first line contains a number  n(1n1000) .

Then  n1  lines follow. Each line contains two numbers  u,v(1u,vn)  , which means there is an edge between  u  and  v .
 

Output
For each testcase, if the tree is special print "YES" , otherwise print "NO".
 

Sample Input
  
  
3 1 2 2 3 4 1 2 2 3 1 4
 

Sample Output
  
  
YES NO
Hint
For the second testcase, this tree is similiar with the given tree: 4 1 2 1 4 3 4
 



问你一棵树是否特殊,一棵树特树当且仅当非叶子结点个数不多于一个。 bfs写一遍~


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "vector"
#include "queue"
using namespace std;
const int MAXN = 1005;
int n;
bool vis[MAXN];
vector<int> v[MAXN];
void bfs()
{
	queue<int> q;
	int sum = 1;
	q.push(1);
	vis[1] = true;
	while(!q.empty()) {
		int x = q.front(), tmp = 0;
		q.pop(); 
		for(int i = 0; i < v[x].size(); ++i) {
			int y = v[x][i];
			if(vis[y]) continue;
			vis[y] = true;
			tmp++;
			q.push(y);
		}
		sum += tmp;
		if(tmp != 1) break;
	}
	if(sum == n) printf("YES\n");
	else printf("NO\n");
}
int main(int argc, char const *argv[])
{
	while(scanf("%d", &n) != EOF) {
		memset(vis, false, sizeof(vis));
		for(int i = 0; i <= n; ++i)
			v[i].clear();
		for(int i = 0; i < n - 1; ++i) {
			int x, y;
			scanf("%d%d", &x, &y);
			v[x].push_back(y);
			v[y].push_back(x);
		}
		bfs();
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值