eclipse 3.0 启动出错(SAXParserFactory找不到)的解决办法

原创 2004年10月14日 10:07:00

以下摘自: http://blog.itpub.net/post/325/1535

--------------------------------------------------------

错误日志记录如下:

eclipse.buildId=I200405211200
java.version=1.3.1_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN

java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
 at java.net.URLClassLoader$1.run(Unknown Source)


仔细看看java的版本,其实很简单

3.0的 eclipse要的jdk版本比较高,怎么也得1.4以上吧:-)

换了个1.5的,就ok了。
-------------------------------------------------------------------
为什么会出现这种情况呢?我回想了一下我出现这个错误的
过程,是因为最近我安装了一次oracle 9.2.0.1, 结果,系统环境
中的JRE 就变成了 oracle 自带的 jdk 1.3.1. 所以出现了上面的
情况。

版权声明:本文为博主原创文章,未经博主允许不得转载。

java SAXParserFactory解析xml文件

申明:个人学习总结,经供参考
  • u011698346
  • u011698346
  • 2014年09月20日 09:55
  • 866

eclipse启动tomcat后显示找不到指定文件路径

重新部署tomcat,重新安装tomcat跟更换workspace都试过,还是这样
  • qq_40425694
  • qq_40425694
  • 2017年11月23日 15:34
  • 151

启动eclipse提示找不到虚拟机解决办法

cong y 在eclipse安装路径下的eclipse.ini文件里开始添加以下2行显式指定路径: -vm D:\Java\jdk1.6.0_31\bin\javaw.ex...
  • mengzhejin
  • mengzhejin
  • 2014年07月10日 10:39
  • 3589

Eclipse——打开eclipse,报错:找不到java虚拟机

报错: 有以下几种解决方法: 1、在eclipse根目录下找到eclipse.ini,在文件最后添加如下两行内容: -vm E:\Tools\Java\jdk1.7.0_79\...
  • wttykj
  • wttykj
  • 2017年08月01日 13:22
  • 1529

ubuntu 正确安装jdk后,eclipse从快捷方式打开找不到jvm

今天重装系统,碰到了个古怪的问题,在正确配置好jdk路径后,解压缩版的eclipse能从命令行正常启动,从快捷方式启动时却提示找不到java路径。经过一番苦找之后,从正确安装jdk后,eclipse找...
  • kc171154
  • kc171154
  • 2015年08月12日 17:10
  • 1811

Eclipse中启动Tomcat服务器出错的解决办法

很多初学者在接触Tomcat的时候都会遇到一些问题,例如启动不了,报端口出错,占用之类的问 题,本人初次在Eclipse中启动Tomcat服务器时也碰到了此类问题,纠结了很久才得以解决,如果你 知...
  • WZhi_295899448
  • WZhi_295899448
  • 2011年11月22日 15:28
  • 399

关于eclipse启动出错问题的解决办法

!SESSION 2011-05-17 10:14:48.625 -----------------------------------------------eclipse.buildId=M201...
  • jkptthui
  • jkptthui
  • 2011年05月17日 10:55
  • 6984

启动出错的解决办法

如果改了/etc/lilo.conf没有运行lilo -v,或者在运作比较大的情况下没有运行grub-install /dev/hda,启动时就会出错,比如著名的Kernel panic错误,不认文件...
  • xzknet
  • xzknet
  • 2006年09月01日 16:48
  • 1190

eclipse启动tomcat 报错: 找不到或无法加载主类

今天配置eclipse 下tomcat 时 总是报 eclipse启动tomcat 报错: 找不到或无法加载主类 后来发现是 eclipse中配置的jre 加了参数导致。删掉参数启动正常。 操作...
  • wlim82
  • wlim82
  • 2015年03月17日 14:32
  • 2566

解决64位的Eclipse 启动时,找不到jvm.dll的问题和Eclipse中出现乱码的问题

经测试可行的办法在 Eclipse解压包的根目录找到
  • aadd1988
  • aadd1988
  • 2014年04月25日 15:22
  • 2921
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:eclipse 3.0 启动出错(SAXParserFactory找不到)的解决办法
举报原因:
原因补充:

(最多只允许输入30个字)