【杭电oj5671】Matrix

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1409    Accepted Submission(s): 561


Problem Description
There is a matrix  M  that has  n  rows and  m  columns  (1n1000,1m1000) .Then we perform  q(1q100,000)  operations:

1 x y: Swap row x and row y  (1x,yn) ;

2 x y: Swap column x and column y  (1x,ym) ;

3 x y: Add y to all elements in row x  (1xn,1y10,000) ;

4 x y: Add y to all elements in column x  (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T20)  indicating the number of test cases. For each test case:

The first line contains three integers  n m  and  q .
The following  n  lines describe the matrix M. (1Mi,j10,000)  for all  (1in,1jm) .
The following  q  lines contains three integers  a(1a4) x  and  y .
 

Output
For each test case, output the matrix  M  after all  q  operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 
 

这道题主要是学习了一个思想,就是直接对数组元素进行交换或操作是很 耗时间的,所以可以另开一个数组对原数组的下标进行关联,这样每次操作只需要一次就行了,这就是O(n)的复杂度就能轻松ac了。很巧妙。。。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define LCA(s,x) memset(s,0,sizeof(s))
using namespace std;
const int N = 1005;
int map[N][N],a[N],b[N],c[N],d[N];
int main() {
	int T;
	scanf("%d",&T);
	while(T--) {
		int n,m,q;
		LCA(b,0);
		LCA(d,0);
		for(int i=1; i<=N; i++) {
			a[i]=i;
			c[i]=i;
		}
		scanf("%d%d%d",&n,&m,&q);
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=m; j++) {
				scanf("%d",&map[i][j]);
			}
		}
		while(q--) {
			int k,x,y,temp;
			scanf("%d%d%d",&k,&x,&y);
			switch(k) {
				case 1: {
					temp=a[x];
					a[x]=a[y];
					a[y]=temp;
					break;
				}
				case 2: {
					temp=c[y];
					c[y]=c[x];
					c[x]=temp;
					break;
				}
				case 3: {
					b[a[x]]+=y;
					break;
				}
				case 4: {
					d[c[x]]+=y;
					break;
				}
			}
		}
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=m; j++) {
				if(j==1)
					printf("%d",map[a[i]][c[j]]+b[a[i]]+d[c[j]]);
				else
					printf(" %d",map[a[i]][c[j]]+b[a[i]]+d[c[j]]);
			}
			printf("\n");
		}
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值