Matrix Chain Multiplication
Problem Description
Matrix multiplication problem is a typical example of dynamical programming.
Suppose you have to evaluate an expression like ABCDE where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 5010 matrix, B a 1020 matrix and C a 205 matrix.
There are two different strategies to compute ABC, namely (AB)C and A(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }
Line = Expression
Expression = Matrix | “(” Expression Expression “)”
Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”
Output
For each expression found in the second part of the input file, print one line containing the word “error” if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
Sample Input
9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output
0
0
0
error
10000
error
3500
15000
40500
47500
15125
这道题的主要难点是在表达式的处理上,我的思路是用栈处理。
一遍AC,好开心。
#include<iostream>
#include<map>
#include<stack>
using namespace std;
struct Node{
int row;
int col;
};
int isLegal(Node a, Node b)//判断是否合法
{
if(a.col != b.row)
return false;
return true;
}
int main()
{
map<char, Node> mp;
int n;
cin>>n;
for(int i=0;i<n;i++)
{
char c;
Node node;
cin>>c>>node.row>>node.col;
mp[c] = node;
}
string str;
while(cin>>str)
{
map<char, Node> mp_copy(mp);//初始化
int sum = 0;
stack<char> st;
int len = str.length();
if(len == 1)
{
cout<<"0"<<endl;
continue;
}
int flag = 0;//标记是否合法
for(int i=0;i<len;i++)
{
if(str[i] == '(')
st.push(str[i]);
else if(str[i] == ')')
{
char temp = st.top(); //弹出栈中的字母
st.pop();//弹出栈中的字母
if(st.top() == '(')
st.pop();//弹出栈中的(
if(st.empty())//判断是否栈空
break;
if(st.top()=='(')//判断是否栈顶继续为(
st.push(temp);
else{
char last = st.top();
if(!isLegal(mp_copy[last], mp_copy[temp])){//不合法
flag = -1;
break;
}
else{//合法
sum += mp_copy[last].row * mp_copy[temp].row * mp_copy[temp].col;
mp_copy[last].col = mp_copy[temp].col;
}
}
}
else{//为字母
char temp = st.top();
if(temp == '(')
st.push(str[i]);
else{//为字母
if(!isLegal(mp_copy[temp], mp[str[i]])){//不合法
flag = -1;
break;
}
else{//合法
sum += mp_copy[temp].row * mp[str[i]].row * mp[str[i]].col;
mp_copy[temp].col = mp[str[i]].col;
}
}
}
}
if(flag == -1)
cout<<"error"<<endl;
else
cout<<sum<<endl;
}
return 0;
}