POJ2255Tree Recovery(二叉树)

Tree Recovery
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11241 Accepted: 7048

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB
题目大意:告诉你一个二叉树的前序遍历,中序遍历,求它的后序遍历
基础知识:前序遍历 根左右,中序遍历 左根右, 后序遍历 左右根
前序遍历的第一个 后序遍历的最后一个一定为根
因此我们从前序遍历入手 在中序遍历中找到跟的位置 然后将跟拿走 剩下 左子树和右子树 剩下的依然是两个树 继续进行递归 然后得到整个的后续遍历
例如
前序DBACEGF S1 中序ABCDEFG S2
第一个跟为D 在s2中找到D 剔除 剩下 ABC EFG 分别为左右子树
然后再左子树中找到B 左子树中存在 左子树中剩下 A,C分别为左右子树 递归完毕
在右子树中进行递归 首先在s1中找到 E 然后剩下FG 都在E的右子树上 然后S1中搜到 G 剩下F,参照S2可知 为G的左儿子。
代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;


const int N = 30;


char pre[N],mid[N];


int n;


void make_tree(int l,int r)
{
    int k;
    if(l>r)
        return;
    for(k=l;k<=r;k++)
        if(pre[n]==mid[k])
           break;
    n++;
    make_tree(l,k-1);//建左子树:顺序不可颠倒
    make_tree(k+1,r);//建右子树;
    cout<<mid[k];
}


int main()
{
    while(cin>>pre>>mid){
        n=0;
        int len=strlen(pre)-1;
        make_tree(0,len);
        puts("");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值