Return of the Nim----Nim博弈+威佐夫博弈 山东省第八届省赛A题

Return of the Nim

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

Sherlock and Watson are playing the following modified version of Nim game:

  • There are n piles of stones denoted as ,,...,, and n is a prime number;
  • Sherlock always plays first, and Watson and he move in alternating turns. During each turn, the current player must perform either of the following two kinds of moves:
    1. Choose one pile and remove k(k >0) stones from it;
    2. Remove k stones from all piles, where 1≤kthe size of the smallest pile. This move becomes unavailable if any pile is empty.
  • Each player moves optimally, meaning they will not make a move that causes them to lose if there are still any better or winning moves.

Giving the initial situation of each game, you are required to figure out who will be the winner

Input

The first contains an integer, g, denoting the number of games. The 2×g subsequent lines describe each game over two lines:
1. The first line contains a prime integer, n, denoting the number of piles.
2. The second line contains n space-separated integers describing the respective values of ,,...,.

  • 1≤g≤15
  • 2≤n≤30, where n is a prime.
  • 1≤pilesi where 0≤in−1
Output

For each game, print the name of the winner on a new line (i.e., either "Sherlock" or "Watson")

Example Input
2
3
2 3 2
2
2 1
Example Output
Sherlock
Watson

题目链接:http://www.sdutacm.org/onlinejudge2/index.php/Home/Index/problemdetail/pid/3893.html


题目很好,第一次碰见这种博弈

题目的意思是说有两个人进行博弈,现有两种操作,一种是全部堆取k个,但是k不可超过最小堆中的石子个数,另一种是可以从任意一堆中取任意个数的石子,题目保证输入的堆数是素数。

我们可以很惊讶的发现,如果去掉第一种操作就是个裸地Nim,如果去掉第二种操作就是裸地威佐夫,所以这个题的题解就是Nim+威佐夫,威佐夫就不用讲了,只有堆数为2的时候才是威佐夫,直接上板子就可以了,然后我们考虑Nim,也就是n>=3的时候,我们就不讲第二种操作了,就是裸地Nim,现在我们来看第一种操作会造成什么样的影响。

举个栗子(莫名想到了栗主席...)

假如说现在有三堆,个数分别是15,6,9,然后我们可以发现这已经在Nim的平衡状态了,我们写成二进制更好看一些

1 1 1 1

0 1 1 0

1 0 0 1

我们随便取一个k,假如说就取2,那么已经在Nim平衡状态的这个状态肯定会被破坏,就是不平衡了,单看倒数第二位,前两个数的倒数第二位为0,最后一个数的倒数第二位为1 ,只看倒数第二位就知道三个数的异或和一定不为0,所以不在平衡状态,又因为题目保证了素数(其实这里挺坑的,奇数堆就可以),所以如果已经在平衡状态的话,减k操作和普通的Nim操作一定会破坏平衡状态,如果不在平衡状态的话,普通的Nim操作或者是减k操作一定可以达到一种平衡状态(普通的Nim操作就可以,减k有的时候也可以,比如7,6,5所有堆同时减去4就达到了平衡状态,单把最后一堆减4个也是平衡状态),然后发现减k操作好像对于Nim博弈来说...并没有什么影响,所以这个题的题解就是如果只有两堆,就是裸地威佐夫博弈,如果是大于两堆,就是裸地Nim

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1000];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        if(n==2){
            if(a[0]<a[1]){
                swap(a[0],a[1]);
            }
            if(floor((a[0]-a[1])*((sqrt(5.0)+1.0)/2.0))!=a[1]){
                printf("Sherlock\n");
            }
            else{
                printf("Watson\n");
            }
        }
        else{
            int k=a[0];
            for(int i=1;i<n;i++){
                k^=a[i];
            }
            if(k==0){
                printf("Watson\n");
            }
            else{
                printf("Sherlock\n");
            }
        }
    }
    return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值