Return of the Nim

Return of the Nim

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

Sherlock and Watson are playing the following modified version of Nim game:

  • There are n piles of stones denoted as ,,...,, and n is a prime number;
  • Sherlock always plays first, and Watson and he move in alternating turns. During each turn, the current player must perform either of the following two kinds of moves:
    1. Choose one pile and remove k(k >0) stones from it;
    2. Remove k stones from all piles, where 1≤kthe size of the smallest pile. This move becomes unavailable if any pile is empty.
  • Each player moves optimally, meaning they will not make a move that causes them to lose if there are still any better or winning moves.

Giving the initial situation of each game, you are required to figure out who will be the winner

Input

The first contains an integer, g, denoting the number of games. The 2×g subsequent lines describe each game over two lines:
1. The first line contains a prime integer, n, denoting the number of piles.
2. The second line contains n space-separated integers describing the respective values of ,,...,.

  • 1≤g≤15
  • 2≤n≤30, where n is a prime.
  • 1≤pilesi where 0≤in−1
Output

For each game, print the name of the winner on a new line (i.e., either "Sherlock" or "Watson")

Example Input
2
3
2 3 2
2
2 1
Example Output
Sherlock
Watson
Hint
Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)


Nim博弈+威佐夫博弈
堆数为2时是威佐夫,当堆数>=3时是Nim;做题时并不会博弈,现在才算了解。
http://www.cnblogs.com/kuangbin/archive/2011/08/28/2156426.html
代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        if(n==2)
        {
            if(a[0]<a[1])
            {
                swap(a[0],a[1]);
            }
            if(floor((a[0]-a[1])*((sqrt(5.0)+1.0)/2.0))!=a[1])
            {
                printf("Sherlock\n");
            }
            else
            {
                printf("Watson\n");
            }
        }
        else
        {
            int k=a[0];
            for(int i=1; i<n; i++)
            {
                k^=a[i];
            }
            if(k==0)
            {
                printf("Watson\n");
            }
            else
            {
                printf("Sherlock\n");
            }
        }
    }
    return 0;
}


/***************************************************
User name: zilong
Result: Accepted
Take time: 0ms
Take Memory: 232KB
Submit time: 2017-07-23 19:08:58
****************************************************/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值