数据结构实验之二叉树三:统计叶子数

sdut原题链接

数据结构实验之二叉树三:统计叶子数
Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output
输出二叉树的叶子结点个数。

Example Input
abc,,de,g,,f,,,

Example Output
3

Hint

Author
xam

以下为accepted代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
typedef struct node
{
    char date;
    struct node *left;
    struct node *right;
}BinTree;
char s[104];
int flag, y1;
BinTree *root;
BinTree * creat()//建树
{
    BinTree * root;
    if(s[flag++] == ','){
        root = NULL;
    }
    else
    {
        root = (BinTree *)malloc(sizeof(BinTree));
        root->date = s[flag-1];
        root->left = creat();
        root->right = creat();
    }
    return root;
}
void leave(BinTree *root)//计算叶子数目
{
    if(root)///判断root是否为NULL
    {
        if(root->left == NULL && root->right == NULL)
        {
            y1++;
        }
        leave(root->left);
        leave(root->right);
    }
}
int main()
{
    while(scanf("%s", s) != EOF)
    {
        flag = y1 = 0;
        root = creat();//调用建树函数
        leave(root);//调用计算叶子数目函数
        printf("%d\n", y1);
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 112KB
Submit time: 2017-02-07 11:46:51
****************************************************/

以下为runtime error代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
typedef struct node
{
    char date;
    struct node *left;
    struct node *right;
}BinTree;
char s[54];
int flag, y1;
BinTree *root;
BinTree * creat()//建树
{
    BinTree * root;
    if(s[flag++] == ','){
        root = NULL;
    }
    else
    {
        root = (BinTree *)malloc(sizeof(BinTree));
        root->date = s[flag-1];
        root->left = creat();
        root->right = creat();
    }
    return root;
}
void leave(BinTree *root)//计算叶子数目
{
    if(!root->left && !root->right){
        y1++;
    }
}
int main()
{
    while(scanf("%s", s) != EOF)
    {
        flag = y1 = 0;
        root = creat();//调用建树函数
        leave(root);//调用计算叶子数目函数
        printf("%d\n", y1);
    }
    return 0;
}


/***************************************************
User name: LEO
Result: Runtime Error
Take time: 0ms
Take Memory: 0KB
Submit time: 2017-02-07 11:31:15
****************************************************/

runtime error cause:
1 在计算叶子数目函数中没有判断root是否为NULL;

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值