【极客blog图文讲解】ruby以及Jekyll的环境配置(针对mac linux)

标签: rubyjekyllblog极客
4070人阅读 评论(0) 收藏 举报
分类:

(转载请注明出处:http://blog.csdn.net/buptgshengod

一.背景

       你还在为想建立个人网站而没有免费稳定空间而苦恼么?这里将图文并茂讲解最geek的个人主页搭建方法-gitpage的实现。我们通过一个与git相连的博客工具Jekyll实现个人主页的搭建,Jekyll是由ruby语言编写。ruby语言是一种简单的绝对面向对象语言,有日本人发明。

二.安装ruby

      jekyll要求ruby语言的版本要至少1.9.2。然而蛋疼的是mac自带的版本是1.8.6。所以我们要先升级ruby的版本!

       第一步 安装RVM

       RVM(Ruby Version Manager),用来控制ruby的版本!可以一键安装,这里要用到git,没有配置git的同学请查看我前面的关于git的博客。
     
 打开shell,输入命令
url -L https://get.rvm.io | bash -s stable --rails --autolibs=enabled
     
 安装完,输入
rvm list
       如果是如图显示,则安装成功

        第二步  安装ruby

这时候会遇到问题,因为GFW,也就是**的原因,被墙了,所以我们先更改源地址为淘宝源!

方法如下
gem sources -a http://ruby.taobao.org/
gem update --system

这时候输入
rvm install ruby-2.0.0
如下图所示安装

失败了,可以多试几次,活着google下原因,反正我是安了挺长时间!

       第三步  安装jekyll

要先输入如下,这样就不用每次进行jekyll操作都要输入一次使用ruby的命令
rvm --default use ruby-2.0.0

更新gem
sudo gem update --system

安装jekyll
sudo gem install jekyll

如果成功的话可以查看版本,如下
jekyll -v

累死了,具体的使用,下次再讲吧,have fun!


1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    我的微信公众号

    作者公众号:凡人机器学习

    凡人机器学习

    作者新书《机器学习实践应用》

    主要讲述算法和业务的结合,适合初学者

    机器学习实践应用

    京东地址

    个人资料
    • 访问:695556次
    • 积分:9706
    • 等级:
    • 排名:第1889名
    • 原创:220篇
    • 转载:39篇
    • 译文:0篇
    • 评论:433条
    博客专栏
    统计