hdu1806——Frequent values

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3
大意:n个非递减数m条询问,输出询问区间内相同频率最高的次数 思路:创建a2数组记录出现次数:1,2,1,2,3,4,1,1,2,3,注意区间左边处理情况
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 100003
using namespace std;
int dp[N][30],a1[N],a2[N],n;
void RMQ()
{
    int i,j;
    for(j=1; 1<<j<=n; j++)
        for(i=1; i+(1<<j)-1<=n; i++)
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
int main()
{
    int m,i,a,b;
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        scanf("%d",&a1[1]);
        a2[1]=1;
        dp[1][0]=1;
        for(i=2; i<=n; i++)
        {
            scanf("%d",&a1[i]);
            if(a1[i]==a1[i-1])
            {
                a2[i]=a2[i-1]+1;
                dp[i][0]=a2[i];
            }
            else
            {
                a2[i]=1;
                dp[i][0]=1;
            }
        }
        RMQ();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(a>b)
                swap(a,b);
            int sum=0;
            for(i=a; i<=b; i++)
            {
                if(a2[i]==1)
                    break;
                sum++;
            }
            if(i==b+1)
                printf("%d\n",sum);
            else
            {
                int k=log(b-i+1.0)/log(2.0);
                printf("%d\n",max(sum,max(dp[i][k],dp[b-(1<<k)+1][k])));
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值