【模拟】HDU 1008 Elevator【题解】

该博客详细解析了HDU 1008 Elevator问题,介绍了如何计算电梯在满足给定楼层请求时的总时间。题目中电梯上行一层耗时6秒,下行一层耗时4秒,每站停留5秒。博客提供了样例输入和输出,并分享了AC代码来解决这个问题。
摘要由CSDN通过智能技术生成

Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71305 Accepted Submission(s): 39169

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41

Author
ZHENG, Jianqiang

题意

这个题的意思就是你要坐电梯,这个电梯每向上前进一层需要花费6s,下降一层需要花费4s。停靠的时候还需要花费5s(大概是用来开门吧)
例如:
从0到4 需要花费 6*(4-0)+5 也就是29s。
但是比较坑爹的是,即使在同一层,比如从4到4 还需要花5s。(⊙o⊙)

AC代码:

#include<cstdio>
#include<iostream>

long long int sum;

void add(int a,int b){
    if(a<b)
        sum+= (b-a)*6+5;
    else
        sum+= (a-b)*4+5;
}

int main(){
    int tmp1,tmp2;
    int n;
    while(~scanf("%d",&n)&&n){
        sum=tmp2=0;
        for(int i=0;i<n;++i){
            tmp1=tmp2; /*这道题没必要用数组存储,两个变量就可以完成所有的录入。*/
            scanf("%d",&tmp2);
            add(tmp1,tmp2);
        }
        printf("%lld\n",sum);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值