POJ2299 Ultra-QuickSort 【树状数组】+【hash】

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 39529 Accepted: 14250

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

注意结果要用long long存储。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 500002
using std::sort;

int tree[maxn], ori[maxn], hash[maxn];
long long ans;

int getHash(int val, int n)
{
	int left = 0, right = n - 1, mid;
	while(left <= right){
		mid = (left + right) >> 1;
		if(val < hash[mid]) right = mid - 1;
		else if(val > hash[mid]) left = mid + 1;
		else return mid + 1;
	}
}

int lowBit(int pos){ return pos & (-pos); }

int getSum(int pos)
{
	int sum = 0;
	while(pos > 0){
		sum += tree[pos];
		pos -= lowBit(pos);
	}
	return sum;
}

void update(int pos, int n)
{
	ans += (pos - 1 - getSum(pos - 1));
	while(pos <= n){
		++tree[pos];
		pos += lowBit(pos);
	}
}


int main()
{
	int n, i;
	while(scanf("%d", &n), n){
		for(i = 0; i < n; ++i){
			scanf("%d", ori + i);
			hash[i] = ori[i];
		}
		
		sort(hash, hash + n);		
		for(i = 0; i < n; ++i)
			ori[i] = getHash(ori[i], n);			
		memset(tree, 0, sizeof(tree));
		
		ans = 0;
		for(i = 0; i < n; ++i) update(ori[i], n);
		printf("%lld\n", ans);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
编译原理是计算机专业的一门核心课程,旨在介绍编译程序构造的一般原理和基本方法。编译原理不仅是计算机科学理论的重要组成部分,也是实现高效、可靠的计算机程序设计的关键。本文将对编译原理的基本概念、发展历程、主要内容和实际应用进行详细介绍编译原理是计算机专业的一门核心课程,旨在介绍编译程序构造的一般原理和基本方法。编译原理不仅是计算机科学理论的重要组成部分,也是实现高效、可靠的计算机程序设计的关键。本文将对编译原理的基本概念、发展历程、主要内容和实际应用进行详细介绍编译原理是计算机专业的一门核心课程,旨在介绍编译程序构造的一般原理和基本方法。编译原理不仅是计算机科学理论的重要组成部分,也是实现高效、可靠的计算机程序设计的关键。本文将对编译原理的基本概念、发展历程、主要内容和实际应用进行详细介绍编译原理是计算机专业的一门核心课程,旨在介绍编译程序构造的一般原理和基本方法。编译原理不仅是计算机科学理论的重要组成部分,也是实现高效、可靠的计算机程序设计的关键。本文将对编译原理的基本概念、发展历程、主要内容和实际应用进行详细介绍编译原理是计算机专业的一门核心课程,旨在介绍编译程序构造的一般原理和基本

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值