POJ1240 Pre-Post-erous! 【待完成】

Pre-Post-erous!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2041 Accepted: 1257

Description

We are all familiar with pre-order, in-order and post-order traversals of binary trees. A common problem in data structure classes is to find the pre-order traversal of a binary tree when given the in-order and post-order traversals. Alternatively, you can find the post-order traversal when given the in-order and pre-order. However, in general you cannot determine the in-order traversal of a tree when given its pre-order and post-order traversals. Consider the four binary trees below: 
    a   a   a   a

   /   /     \   \

  b   b       b   b

 /     \     /     \

c       c   c       c


All of these trees have the same pre-order and post-order traversals. This phenomenon is not restricted to binary trees, but holds for general m-ary trees as well. 

Input

Input will consist of multiple problem instances. Each instance will consist of a line of the form 
m s1 s2 
indicating that the trees are m-ary trees, s1 is the pre-order traversal and s2 is the post-order traversal.All traversal strings will consist of lowercase alphabetic characters. For all input instances, 1 <= m <= 20 and the length of s1 and s2 will be between 1 and 26 inclusive. If the length of s1 is k (which is the same as the length of s2, of course), the first k letters of the alphabet will be used in the strings. An input line of 0 will terminate the input. 

Output

For each problem instance, you should output one line containing the number of possible trees which would result in the pre-order and post-order traversals for the instance. All output values will be within the range of a 32-bit signed integer. For each problem instance, you are guaranteed that there is at least one tree with the given pre-order and post-order traversals. 

Sample Input

2 abc cba
2 abc bca
10 abc bca
13 abejkcfghid jkebfghicda
0

Sample Output

4
1
45
207352860

#include <stdio.h>
#include <string.h>
#define maxn 28

char pre[maxn], post[maxn];
int k;

int cal(int n, int m){
	if(m > n / 2) m = n - m;
	int ans = 1;
	for(int i = 0; i < m; ++i)
		ans = ans * (n - i) / (i + 1); //不可以写成 *=
	return ans;
}

int traverse(int l1, int r1, int l2, int r2)
{
	int rt, num = 0, ans = 1;
	while(l1 < r1){
		rt = strchr(post, pre[l1+1]) - post - l2;
		++num;
		ans *= traverse(l1+1, l1+rt, l2, l2+rt);
		l1 += rt; l2 = rt + l2 + 1;
	}
	return ans * cal(k, num);
}

int main()
{
	int len;
	while(scanf("%d%s%s", &k, pre, post) == 3){
		len = strlen(pre);
		--len;
		printf("%d\n", traverse(0, len, 0, len));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值