Oh, my goddess

Oh, my goddess
时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Shining Knight is the embodiment of justice and he has a very sharp sword can even cleavewall. Many bad guys are dead on his sword.

One day, two evil sorcerer cgangee and Jackchess decided to give him some colorto see. So they kidnapped Shining Knight's beloved girl--Miss Ice! They built a M x Nmaze with magic and shut her up in it.

Shining Knight arrives at the maze entrance immediately. He can reach any adjacent emptysquare of four directions -- up, down, left, and right in 1 second. Or cleave one adjacent wall in 3

seconds, namely,turn it into empty square. It's the time to save his goddess! Notice: ShiningKnight won't leave the maze before he find Miss Ice.

输入
The input consists of blocks of lines. There is a blank line between two blocks.

The first line of each block contains two positive integers M <= 50 and N <= 50separated by one space. In each of the next M lines there is a string of length N contentsO and #.

O represents empty squares. # means a wall.

At last, the location of Miss Ice, ( x, y ). 1 <= x <= M, 1 <= y <= N.

(Shining Knight always starts at coordinate ( 1, 1 ). Both Shining and Ice's locationguarantee not to be a wall.)
输出
The least amount of time Shining Knight takes to save hisgoddess in one line.
样例输入
3 5
O####
#####
#O#O#
3 4
样例输出
14



个人理解:该题使用优先队列处理

   
   
结果时间运行语言
Accepted40324C/C++
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
void bb();
int x,y,ex,ey,m,n;
char vc[51][51];
int cc[51][51],vx[4]={-1,0,0,1},vy[4]={0,-1,1,0};
struct dear
{
    int x,y,time;
     friend bool operator < (dear a,dear b)//由小到大排列
    {
        return a.time>b.time;
    }
};
int main()
{
    int i,j;
    while(~scanf("%d%d",&m,&n))
  {
    for(i=1;i<=m;i++)
    {
        getchar();//回收回车键储存空间
        for(j=1;j<=n;j++)
        {
            scanf("%c",&vc[i][j]);
        }
    }
    scanf("%d%d",&ex,&ey);
    bb();
  }
    return 0;
}
void bb()
{
    int i;
    memset(cc,0,sizeof(cc));
    priority_queue<dear> pq;
    dear st={1,1,0};
    pq.push(st);
    cc[1][1]=1;
    while(pq.empty()!=true)
    {
        st=pq.top();
        pq.pop();
        if(st.x==ex&&st.y==ey)
        {
            printf("%d\n",st.time);
            return;
        }
        for(i=0;i<4;i++)
        {
            int cx,cy;
            cx=st.x+vx[i];
            cy=st.y+vy[i];
            if(cx<1||cx>m||cy<1||cy>n)
            {
                continue;
            }
            if(!cc[cx][cy])
            {
                int ct=st.time+1;
                if(vc[cx][cy]=='#')
                    ct+=3;
                    dear cp={cx,cy,ct};
                    cc[cx][cy]=1;
                    pq.push(cp);
            }
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值