hdoj 3836 Equivalent Sets 【tarjan 求SCC + 缩点】



Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 3394    Accepted Submission(s): 1170


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

Output
For each case, output a single integer: the minimum steps needed.
 

Sample Input
  
  
4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
 

看九野大大的专题,碰到重题。。。


题意:n个点m条边的有向图,问最少增加多少边使图强连通。

思路:tarjan求出SCC 缩点并求出入度出度,统计入度为0的点和出度为0的点,其中较大的就是结果。


#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define MAXN 20000+10
#define MAXM 600000000+10
#define INF 10000000
using namespace std;
vector<int> G[MAXN];//已推导的公式建立的图 
int low[MAXN], dfn[MAXN];
int dfs_clock;
int sccno[MAXN], scc_cnt;
vector<int> scc[MAXN];//存储SCC的点 
stack<int> S;
bool Instack[MAXN];
int n, m;//n个命题 m次推导
void getMap()
{
	int s, t;
	for(int i = 1; i <= n; i++) G[i].clear(); 
	while(m--)
	{
		scanf("%d%d", &s, &t);
		G[s].push_back(t);
	} 
}
void tarjan(int u, int fa)
{
	int v;
	low[u] = dfn[u] = ++dfs_clock;
	S.push(u);
	Instack[u] = true;
	for(int i = 0; i < G[u].size(); i++)
	{
		v = G[u][i];
		if(!dfn[v])
		{
			tarjan(v, u);
			low[u] = min(low[u], low[v]);
		} 
		else if(Instack[v])
		low[u] = min(low[u], dfn[v]);
	}
	if(low[u] == dfn[u])
	{
		scc_cnt++;
		scc[scc_cnt].clear();
		for(;;)
		{
			v = S.top(); S.pop();
			Instack[v] = false;
			sccno[v] = scc_cnt;
			scc[scc_cnt].push_back(v);
			if(v == u) break;
		}
	} 
}
void find_cut(int l, int r)
{
	memset(low, 0, sizeof(low));
	memset(dfn, 0, sizeof(dfn));
	memset(sccno, 0, sizeof(sccno));
	memset(Instack, false, sizeof(Instack));
	dfs_clock = scc_cnt = 0;
	for(int i = l; i <= r; i++)
	if(!dfn[i]) tarjan(i, -1); 
}
int in[MAXN], out[MAXN];//SCC入度 出度 
void suodian()//缩点 
{
	for(int i = 1; i <= scc_cnt; i++) in[i] = out[i] = 0; 
	for(int i = 1; i <= n; i++)
	{
		for(int j = 0; j < G[i].size(); j++)
		{
			int u = sccno[i];
			int v = sccno[G[i][j]];
			if(u != v)
			out[u]++, in[v]++;
		} 
	} 
}
void solve()
{
	if(scc_cnt == 1)
	{
		printf("0\n");
		return ;
	}
	int sumin = 0, sumout = 0;//入度为0的点数 出度为0的点数
	for(int i = 1; i <= scc_cnt; i++)
	{
		if(in[i] == 0) sumin++;
		if(out[i] == 0) sumout++;
	} 
	printf("%d\n", max(sumin, sumout));
} 
int main()
{
	while(scanf("%d%d", &n, &m) != EOF)
	{
		getMap();
		find_cut(1, n);//找SCC
		suodian(); 
		solve(); 
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值