poj_3687 Labeling Balls

Labeling Balls

Time  Limit: 1000MS

Memory  Limit: 65536K

Total  Submissions: 7681

Accepted: 2060

题目链接:http://poj.org/problem?id=3687

Description

Windy has N balls of distinct weights from 1unitto Nunits. Now he tries to label them with 1 to N in such away that:

1.  No two balls share the same label. 
2.  The labeling satisfies several constrains like     "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number oftest case.The first line of each test case contains two integers, N (1 ≤ N≤ 200) and M (0 ≤ M ≤ 40,000). Thenext Mline eachcontain two integers a and b indicating the ball labeled with amust be lighter than the one labeledwith b. (1≤ a, bN)There is a blankline before each test case.

Output

For each test case output on a single linethe balls'weights from label 1 to label N. If several solutions exist, youshouldoutput the one with the smallest weight for label 1, then with thesmallestweight for label 2, then with the smallest weight for label 3 and soon... Ifno solution exists, output -1 instead.

Sample Input

5

 

4 0

 

4 1

1 1

 

4 2

1 2

2 1

 

4 1

2 1

 

4 1

3 2

Sample Output

1 2 3 4

-1

-1

2 1 3 4

1 3 2 4

Source

POJFounder MonthlyContest – 2008.08.31, windy7926778

 

题目大意:

         输入T个测试案例,接下来输入N个点,M条边,接下来M行输入每条边的起点和终点,如果边产生回路,那么输出-1,否则按照输入的a轻于b,剩下的值就按从大到小输出。

解题思路:

         将输入的n行建立有向图,如果该图产生回路,那么输出-1,如果不产生回路,将入度为0的点放进优先队列中,优先队列从大到小排序,每个队列按顺序出队,当出队的数与其他点有边存在,就在相应该点的入度减一,然后在判断是否入度为0,如果为0再次入队。本题一个比较容易出错的就是判重,如果输入两个相同的ab,那么如果没有判重将会输出0,判重就在输入边时判断该边是否已经存在,如果存在该边的入度就不在自加。

/*

两组比较好的测试案例:

第二个测试案例有5个,但是有2个一样的,所以按4个算

2

 

54

51

42

13

23

 

105

41

81

78

41

28

ans:

24 5 3 1        逆向建图

51 6 2 7 8 3 4 9 10  没有判重边的话就输出 -1

*/

代码:

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<queue>

using namespace std;

int g[210][210];
int degree[210];//入度
int value[210];
priority_queue<int> q;//定义优先队列

//得到入度为0的点
int toposort(int n)
{
	int j=n;
	for(int i=1;i<=n;i++)
	{
		if(degree[i]==0)
		{
			q.push(i);
		}
	}
	if(q.empty())
		return 0;
	while(!q.empty())
	{
		int t = q.top();
		q.pop();
		value[t]=j;
		j--;
		for(int i=1;i<=n;i++)
		{
			if(g[i][t]!=0)
			{
				g[i][t]=0;
				degree[i]--;
				if(degree[i]==0)
				{
					q.push(i);
				}
			}
		}
	}
	if(j!=0)
		return 0;
	return 1;
}

int main()
{
	int T;
	int n,m;
	int a,b;
	scanf("%d",&T);
	while(T--)
	{
		memset(g,0,sizeof(g));
		memset(degree,0,sizeof(degree));
		scanf("%d%d",&n,&m);
		while(m--)
		{
			scanf("%d%d",&a,&b);
			if(g[a][b]>0)//判重,如果输入一样的那么只算一个
                degree[a]--;
			g[a][b]=1;//a到b的边,起点a,终点b的边
			degree[a]++;
		}
		int x = toposort(n);
		if(x==0)
			printf("-1\n");
		else
		{
			for(int i=1;i<n;i++)
			{
				printf("%d ",value[i]);
			}
			printf("%d\n",value[n]);
		}

	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

疯的世界

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值