CSU 1211: 大整数开平方练习(二分)

CSU 1211: 大整数开平方练习 二分

Description

对大整数开平方,向下取整

Input

每行一个正整数,位数1 <= len <= 1000

Output

每行对应输出正整数的平方根。

Sample Input

37
12345678987654321

Sample Output

6
111111111

Hint

Source

CSGrandeur的数据结构习题

思路:二分,极限过

import java.util.*;
import java.math.*;
public class Main{
    public static void main(String args[]){
        BigInteger i;
        Scanner input = new Scanner(System.in);
        while(input.hasNext()){
            i = input.nextBigInteger();
            BigInteger l = BigInteger.ZERO;
            BigInteger r = i;
            BigInteger mid;
            while(r.subtract(l).compareTo(BigInteger.ZERO) > 0){
                mid = l.add(r.add(BigInteger.ONE)).divide(BigInteger.valueOf(2));
                if(judge(mid,i) == 1)
                    l = mid;
                else
                    r = mid.subtract(BigInteger.ONE);
            }
            System.out.println(l);
        }
    }
    public static int judge(BigInteger x,BigInteger i){
        if(x.multiply(x).compareTo(i) <= 0)
            return 1;
        else return 0;
    }
}
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值