HDU1068,POJ1466——Girls and Boys(二分图最大独立集)

Girls and Boys

点击打开链接http://poj.org/problem?id=1466

点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=1068

Time Limit: 5000MSMemory Limit: 10000K
Total Submissions: 11996Accepted: 5337

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题目描述:
    大二的时候,有人开始了一项研究,研究同学之间的浪漫关系。浪漫关系被定义为一个男孩和一个女孩之间的关系。为了研究的需要,有必要找出满足条件的最大集合:集合内任何两个学生都没有发生浪漫关系。程序需要输出该集合中学生的人数。

如果两个人之间有关系就连一条边,那么题目就是求最大独立集 二分图里面,最大独立集=顶点数-最大匹配 又匹配是两两匹配,所有匹配数要除以2

解题思路:

利用匈牙利算法算出最大匹配数,然后用定点数减去最大匹配数。

代码实现:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <queue>
#include <vector>

using namespace std;
int n;
int mp[505][505];
int vis[505], girl[505];

bool marry( int person )
{
    for( int i=0; i<n; i++ )
    {
        if( vis[i] == 0  && mp[person][i] == 1 )
        {
            vis[i] = 1;
            if( girl[i] == -1 || marry(girl[i]) )
            {
                girl[i] = person;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while( scanf("%d",&n)!=EOF )
    {
        int m = n;
        memset(mp, 0, sizeof(mp));
        int she, love, he;
        while( m-- )
        {
            scanf("%d: (%d)",&she,&love);
            for( int i=0; i<love; i++ )
            {
                scanf("%d",&he);
                mp[she][he] = 1;
            }
        }
        memset(girl, -1, sizeof(girl));
        int pouse = 0;
        for( int i=0; i<n; i++ )
        {
            memset(vis,0,sizeof(vis));
            if( marry (i) )
                pouse++;
        }
        printf("%d\n",n-pouse/2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值