Uva 1292 - Strategic game 树形dp 最小点覆盖

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier (at the node 1).

Input 

The input file contains several data sets in text format. Each data set represents a tree with the following description:
  • the number of nodes
  • the description of each node in the following format:
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 � node_identifiernumber_of_roads
    or
    node_identifier:(0)
The node identifiers are integer numbers between  0  and  n-1 , for  n  nodes ( 0 < n ≤ 1500 ). Every edge appears only once in the input data.

Output 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input 

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output 

1
2
-------------

f[i][0]表示点i属于点覆盖,并且以点i为根的子树中所连接的边都被覆盖的情况下点覆盖集中所包含的最少点数。

f[i][1]表示点i不属于点覆盖,且以i为根的子树中所连接的边都被覆盖的情况下点覆盖集中所包含最少点的个数。

① f[i][0]=1+sum{ min(f[v][0], f[v][1]) };

② f[i][1]=sum{ f[v][0] };

-------------

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn=3111;
const int INF=1e9;

struct EDGENODE
{
    int to,next;
} edges[maxn];
int head[maxn],edge;
void addedge(int u,int v)
{
    edges[edge].to=v,edges[edge].next=head[u],head[u]=edge++;
    edges[edge].to=u,edges[edge].next=head[v],head[v]=edge++;
}
void init_edges()
{
    memset(head,-1,sizeof(head));
    edge=0;
}
int n;
int f[maxn][2];
void dp(int u,int pa)
{
    f[u][0]=1;
    f[u][1]=0;
    for (int k=head[u]; k!=-1; k=edges[k].next)
    {
        int v=edges[k].to;
        if (v==pa) continue;
        dp(v,u);
        f[u][0]+=min(f[v][0],f[v][1]);
        f[u][1]+=f[v][0];
    }
}

int main()
{
    while (~scanf("%d",&n))
    {
        int u,v,t;
        init_edges();
        for (int i=0; i<n; i++)
        {
            scanf("%d:(%d)",&u,&t);
            while (t--)
            {
                scanf("%d",&v);
                addedge(u,v);
            }
        }
        dp(0,-1);
        printf("%d\n",min(f[0][0],f[0][1]));
    }
    return 0;
}







  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值