Course(水题)

Course

时间限制:1000 ms |  内存限制:65535KB

【问题描述】

Here is one schoolmate's all the courses he hasstudied and scores he got (sorted by chronological order). So could you tell mehow many time he successfully update his scores of courses?

【输入】

Thefirst of input is an integer T which stands for the number of test cases. Foreach test case the first line is an integer N (1 <= N <= 100) whichstands for the number of courses he has studied. Then following N lines, eachline contains a string (only contains letters and the length is no more than30,which stands for the course name) and an integer (0<=integer<=100,which stands for the score of the course),separated by a space.

 

Remember:the best way is getting the best score in one time.

Studyone course many times is not a recommended choice!

【输出】

For each test caseoutput the number of times he update successfully.

【样例输入】

6

CProgramming70

DataStructrue 80

CProgramming 80

CProgramming 60

CProgramming 90

DataStructrue 70



2

CompilerTheory 95

Network 90

【样例输出】

2

0

源代码如下:

#include<stdio.h>
#include<string.h>
struct node
{
 char str[32];
}s[101];
int main()
{
 int n,t,count,a[101];
 scanf("%d",&t);
 while(t--)
 {
  count=0;
  int i,j;
  scanf("%d",&n);
  for(i=0;i<n;i++)
  {
   scanf("%s %d",s[i].str,&a[i]);
  }
  for(i=0;i<n-1;i++)
  {
   for(j=i+1;j<n;j++)
   {
    if(strcmp(s[i].str,s[j].str)==0&&a[i]<a[j]&&a[j]!=-1&&a[i]!=-1)
    {
      a[i]=-1;
      count++;         
    }
    if(strcmp(s[i].str,s[j].str)==0&&a[i]>a[j])
    {
     a[j]=-1;
    }
   }
  }
  printf("%d\n",count);
 }
 }

//水题:只是向提醒自己这一种方法,,求最长单调子序列的程度。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值