HDU 5240 Exam (好水的题)

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 703    Accepted Submission(s): 354


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has  n  exams. They are all hard, but their difficulties are different. DRD will spend at least  ri  hours on the  i -th course before its exam starts, or he will fail it. The  i -th course's exam will take place  ei  hours later from now, and it will last for  li  hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

Input
First line: an positive integer  T20  indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer  n105 , and  n  lines follow. In each of these lines, there are 3 integers  ri,ei,li , where  0ri,ei,li109

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where  x  is the number of test cases, and  ans  is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 
    
Sample Output
  
  
Case #1: NO Case #2: YES
 
   一上来就发现是一道水题,要参加好多考试,给出复习一门课需要的时间,距离考试还剩下的时间,考试进行的时间,算是否能复习完。直接看代码就能懂
  注意:需要减掉上一次考试所拥有的复习时间
   
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
    int r,e,l;
};
node p[100500];
bool cmp(node a,node b)
{
    return a.e<b.e;
}
int main()
{
    int n,m,i,j,k=1,sum;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&p[i].r,&p[i].e,&p[i].l);
        }
        sort(p,p+n,cmp);
        sum=p[0].e-p[0].r;
        if(sum<0)
        {
            printf("Case #%d: NO\n",k++);
            continue;
        }
        else
        {
            for(i=1;i<n;i++)
            {
                sum+=p[i].e;
                sum-=p[i-1].l;
                sum-=p[i].r;
                sum-=p[i-1].e;
                if(sum<0)
                {
                    printf("Case #%d: NO\n",k++);
                    break;
                }
            }
            if(sum>0)
            {
                printf("Case #%d: YES\n",k++);
            }
        }
    }
    return 0;
}

  
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值