【打CF,学算法——一星级】Gym 100548A Built with Qinghuai and Ari Factor (Asia Xian)

【CF简介】

提交链接:Built with Qinghuai and Ari Factor


题面:

Built with Qinghuai and Ari Factor
Description

DISCLAIMER: All names, incidents, characters and places appearing in this problem
are fictitious. Any resemblance to actual events or locales or real persons, living
or dead, is purely coincidental.
Shamatisan is a somewhat famous smartphone maker in China, they built smartphones
that hope to contend with Abble and Dami for the hearts, minds and the wallets of China’s
consumers. They have a famous advertising word, saying that Shamatisan phones are built
with Qinghuai (a concept which is hard to explain in English). Their latest phone T-1 has
just began taking reservations recently, or to be precious, at the beginning of this month. But
those who are tracking its progress on Aripapapa’s online store Skyat noticed an interesting
fact that has led to an apology by the online shopping site.
Those (being like sleuths in this story) who are always curious about questions like “In
how many attoseconds1 were the Dami phones sold out?” found something unusual about the
reservation count of Shamatisan T-1. It always has a divisor three! What’s the logic behind
this mystery? A bit of digging into the site coding showed that the number of reservations
had been multipled by three. After this discovery, people started rumors like “Three is the
Qinghuai factor, applied broadly by Shamatisan internally.” and began to call integers, which
are divisible by three, Qinghuai numbers. They also defined if all elements in a sequence are
Qinghuai numbers, the sequence itself is said to be built with Qinghuai. Moreover, after some
research, people found that there is a feature called “Buy Buy Buy Ring” on Skyat, causing
all reservation counts multiplied by a factor (possibly 1). The rumor “Any real number can
be represented as an Aripapapa Factor (also known as Ari Factor)” had been spread widely.
Later, an Aripapapa’s spokeswoman said this was an incident and posted an official apology
announcement. It is said that a programmer “made a highly unscientific decision”. As a result,
main programmer of Skyat whose name is Beiguoxia lost his job.
Our protagonist Pike loves to write programs that are able to automatically grab some
data from Internet. As you may already know, such programs are usually called “spider”.
Pike has already collected some sequence using his spider. Now he wonders that if these
sequences are built with Qinghuai. Help Pike to figure out this!
Input
The first line of the input gives the number of test cases, T. T test cases follow.
For each test case, the first line contains an integer n (1 ≤ n ≤ 100), the length of
sequence S. The second line contains n integers, which represent n integers in sequence S.
All the numbers in the input will not exceed 106
.
11 attosecond equals to 10−18 seconds.
1The 2014 ACM-ICPC Asia Xi’an Regional Contest October 26, 2014
Output
For each test case output one line “Case #x: y”, where x is the case number (starting
from 1) and y is “Yes” (without quotes) if the sequence S is built with so-called “Qinghuai”,
otherwise “No” (without quotes).
Samples
Sample Input 

2
3
1 2 3
2
3000 996

Sample Output
Case #1: No
Case #2: Yes
Hints
In the first case, since the sequence contains numbers which are too small to have Qinghuai,
it cannot be called being built with Qinghuai.
In the second case, the first integer is the signage of Shamatisan, and the second integer
represents core values of Aripapapa, we can declare that the sequence is built with Qinghuai.
Also note that the whole problem statement (including hints) had deliberately been written
as a joke, don’t be so serious!


解题:

     签到题,题目神长,然而就两句话有用,就是全部数能整除3,输出yes,否则no。


代码:

#include <iostream>
using namespace std;
int main()
{
	int n,t,tmp;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		bool flag=true;
		cin>>n;
		for(int j=1;j<=n;j++)
		{
			cin>>tmp;
			if(tmp%3)
				flag=false;
		}
		cout<<"Case #"<<i<<": ";
		if(flag)cout<<"Yes\n";
		else cout<<"No\n";
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值