POJ 1080_Human Gene Functions

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 
 
 
题意:两组字符序列进行配对,字符配对对应的值为表中所示,每组字符的前后顺序不能改动,相邻字符间可以插入任意多“-”,求一种情况使得配对值的和最大。
解题思路:DP的方法,我们可以发现求解的过程是可以分阶段的,并且满足每一阶段的决策都是独立的,基于上一阶段的最佳决策。举例,序列s1  s2最后的解是通过两个序列的子序列s1-1  s2-1d的最佳解和s1[end] s2[end]配对值组成,那么s1[end] s2[end]有可能是字母,有可能是‘-’,也就是三种情况:字母配‘-’,字母配字母,‘-’配字母。整理成DP的公式就是:dp[i][j]= max(dp[i-1][j-1]+val[s1[end]][s2[end]], dp[i][j-1]+val['-'][s2[end], dp[i-1][j]+val[s1[end]]['-']]);
有了动态规划的流程,有了公式,我们就可以开始DP了。
 
#include <iostream>
using namespace std;
#define MAX 105

int dp[MAX][MAX];

int matrix[5][5] =
{  
	5,-1,-2,-1,-3,  
	-1,5,-3,-2,-4,  
	-2,-3,5,-2,-2,  
	-1,-2,-2,5,-1,  
	-3,-4,-2,-1,0  
}; 

int getID(char a)
{
	switch (a)
	{
	case 'A': return 0;
	case 'C': return 1;
	case 'G': return 2;
	case 'T': return 3;
	case '-': return 4;
	}
}


int max(int a,int b,int c)
{  
	if(a>=b && a>=c) return a;  
	if(b>=a && b>=c) return b;  
	return c;  
}  
int main()
{
	char s1[MAX];
	char s2[MAX];
	int times, len1, len2;

	//输入次数
	cin>>times;
	while (times--)
	{
		//输入数据
		cin>>len1>>s1>>len2>>s2;
		//初始化决策表
		memset(dp,0,sizeof(dp)); 
		dp[0][0] = 0;
		//计算i,j分别为0的dp
		for (int i=1; i<=len1; i++)
			dp[i][0] = dp[i-1][0] + matrix[getID(s1[i-1])][4];
		for (int i=1; i<=len2; i++)
			dp[0][i] = dp[0][i-1] + matrix[4][getID(s2[i-1])];
		
		//DP,每一阶段的决策中都有3种情况,取其中最好的一种
		for (int i=1; i<=len1; i++)
			for (int j=1; j<=len2; j++)
			{
				int tmp1 = dp[i-1][j] + matrix[getID(s1[i-1])][4];
				int tmp2 = dp[i][j-1] + matrix[4][getID(s2[j-1])];
				int tmp3 = dp[i-1][j-1] + matrix[getID(s1[i-1])][getID(s2[j-1])];
				dp[i][j] = max(tmp1, tmp2, tmp3);
			}
		cout<<dp[len1][len2]<<endl;
	}
	
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值