POJ1080-Human Gene Functions(LCS)

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
Output
The output should print the similarity of each test case, one per line.
Sample Input
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
Sample Output
14
21

分析:

题意:
给出两个字符串str1和str2,要求两个字符串的最大相似度,可以在字符串中插入插入空格(两个字符串都可以插入,使得两个字符串等长),通过这种方式,问最大的相似度是多少?相似度的打分按下表:
在这里插入图片描述
解析:
提意我们很清楚了,但是这里我们要怎么插入才能使相似度最大呢?这里我们要用到动态规划的LCS,LCS是指最长公共子列,它的求解模板是:

for(int i=1;i<=len1;i++)
{
	for(int j=1;j<=len2;j++)
	{
		if(str1[i]==str2[j])
			dp[i][j]=dp[i-1][j-1]+1;
		else
			dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
	}
}

这里dp[i][j]表示str1的前i个字符组成的字符串与str2的前j个字符组成的字符串的最长公共子列的长度,那么我们要怎么将这个思想来解决这道题呢?

我们先给出根据这个思想改写的代码:

for(int i=1;i<=len1;i++)
		{
			for(int j=1;j<=len2;j++)
			{
				dp[i][j]=dp[i-1][j-1]+list[number[str1[i]]][number[str2[j]]];
				dp[i][j]=max(dp[i-1][j]+list[number[str1[i]]][number['-']],dp[i][j]);
				dp[i][j]=max(dp[i][j-1]+list[number['-']][number[str2[j]]],dp[i][j]);
			}
		}

根据那个表,两个字符匹配当然好,但是不匹配的话,就要在str1或者str2中插入一个空格,以获得子列的最大匹配度的最大值!

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<map>
#define N 105

using namespace std;

int list[5][5]={{5,-1,-2,-1,-3},{-1,5,-3,-2,-4},{-2,-3,5,-2,-2},{-1,-2,-2,5,-1},{-3,-4,-2,-1,0}};
map<char,int>number;
int dp[N][N];
char str1[N],str2[N];

int main()
{
	int T,len1,len2;
	number['A']=0;
	number['C']=1;
	number['G']=2;
	number['T']=3;
	number['-']=4;
	scanf("%d",&T);
	while(T--)
	{
		dp[0][0]=0;
		scanf("%d",&len1);
		scanf("%s",str1+1);
		scanf("%d",&len2);
		scanf("%s",str2+1);
		for(int i=1;i<=len1;i++)
		{
			dp[i][0]=dp[i-1][0]+list[number[str1[i]]][4];
		}
		for(int i=1;i<=len2;i++)
		{
			dp[0][i]=dp[0][i-1]+list[4][number[str2[i]]];
		}
		for(int i=1;i<=len1;i++)
		{
			for(int j=1;j<=len2;j++)
			{
				dp[i][j]=dp[i-1][j-1]+list[number[str1[i]]][number[str2[j]]];
				dp[i][j]=max(dp[i-1][j]+list[number[str1[i]]][number['-']],dp[i][j]);
				dp[i][j]=max(dp[i][j-1]+list[number['-']][number[str2[j]]],dp[i][j]);
			}
		}
		printf("%d\n",dp[len1][len2]);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值