City Game

Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R � reserved unit
F � free unit
In the end of each area description there is a separating line.

Output

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0
我们如何能求得最大的矩阵呢?如果枚举出所有子矩阵然后比较大小显然是不可能的。我们还是一个位置一个位置看,只不过我们把它们都认为成属于最大的子矩阵,那我们怎么由这个位置出发,扩充出最大的子矩阵呢?我们设置三个数组up【maxn】【maxn】、left【maxn】【maxn】、right【maxn】【maxn】,接下来我们分别看这三个数组‘
1.up数组——对于一个位置,如果它已经被利用了,则它不可能包含在任意子矩阵中,则up【i】【j】=0;如果它是空地,那我们就要在它的基础上扩充出一个尽可能大的子矩阵,显然这个子矩阵应该尽可能的长,那么如果这个位置的前一行也是空地,那么这个位置就要来增加子矩阵的长度,即up【i】【j】=up【i-1】【j】+1。(i!=0的情况下);up【i】【j】=1(i==0的情况下)。
2.left数组——我们从左到右扫描所有的位置。对于一个位置,如果它是空地,同样它就要可能的属于一个大的子矩阵,那么这个位置就要尽可能的向左扩展。lo用来指向非空地,则如果是第一行,left【i】【j】=lo+1;如果不是第一行,我们就要顾及到上一行是否能扩展到lo+1的位置,所以left【i】【j】=max(lo+1,left【i-1】【j】)。
3.right数组——同left数组,不过是从右向左扫描。
代码如下:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=1000;
int area[maxn][maxn],up[maxn][maxn];
int Left[maxn][maxn],Right[maxn][maxn];

int read_char()
{
	char a;
	for(;;)
	{
		a=getchar();
		if(a=='F') return 0;
		if(a=='R') return 1;
	}
}
int main()
{
	int K;
	cin>>K;
	while(K--)
	{
		int M,N;
		cin>>M>>N;
		for(int i=0;i<M;i++)
			for(int j=0;j<N;j++) area[i][j]=read_char();
		int ans=0;
		for(int i=0;i<M;i++)
		{
			int lo=-1,ro=N;
			for(int j=0;j<N;j++)
			{
				if(area[i][j]==1)
				{
					up[i][j]=0;
					Left[i][j]=0;
					lo=j;
				}
				else
				{
					up[i][j]=(i==0?1:up[i-1][j]+1);
					Left[i][j]=(i==0?lo+1:max(lo+1,Left[i-1][j]));
				}
			}
			for(int j=N-1;j>=0;j--)
			{
				if(area[i][j]==1)
				{
					ro=j;
					Right[i][j]=N;
				}
				else
				{
					Right[i][j]=(i==0?ro-1:min(ro-1,Right[i-1][j]));
					ans=max(ans,up[i][j]*(Right[i][j]-Left[i][j]+1));
				}
			}
		}
		cout<<ans*3<<endl;		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值