IIS安装前已经安装了.NET Framework,安装后如何启用.NETFramework

转载 2012年06月29日 16:21:46

问题一:安装好vs2008再安装iis 却发现iis启动项里没有.NET Framework 2.0选项?

我在win2003+iis安装vs2008,发现iis里面没有.NET Framework 2.0选项,在网上查询了资料,得知:

在MSDN找到了方法,其实可以不用重装.NET,只要运行一下.NET的IIS注册程序aspnet_regiis.exe,在IIS中注册一下就可以正常使用了。

命令所在目录为.NET Frame的安装目录,.NET2.0一般为

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

在此目录下执行aspnet_regiis.exe -i

即可启动NET Framework 2.0

问题二:为什么Framework 3.5为什么在IIS的ASP.NET选项找不到?

VS2008带的Framework 3.5,于是我去IIS ASP.NET里面看看是不是有那个选项.
发现没有.于是乎就想到这是脚本没有映射.用以前注册Framework 2.0的方法,发现找不到aspnet_regiis.exe
注册了.上V3.5里面发现最有可能的是一个叫VFServers.exe还差不多.用命令重新注册还是不行.


我看见 添加删除程序里面 是 framework 3.5,怎么他不能脚本映射那?反正我一直不理解为什么在IIS里面怎么就没有?

按照常理说:VS2003带framework1.1,VS2005 带framework2.0,VS2008说过不是带framework3.0,3.0里面有WCF,这次总应该是Framework3.5了吧? 疑惑中.相信很多人估计和我刚才一样疑惑.

查了半天资料,才得到,原來 ASP.NET 3.5 只是使用 .Net Framework 3.5 的组件(assembly)而已!整个核心的架构还是建立在 .NET 2.0 之上,.NET Framework 的 API 都沒变,只是到了 .NET 3.5 很多 assembly 都重新写过了,且执行的速度也比 .NET 2.0 的组件还快。

所以 ASP.NET 3.5 的程式要安装在 IIS 上不需要特別指定 ASP.NET 3.5 的版本,继续沿用 ASP.NET 2.0 的版本即可,但作業系統本身必須要先安裝 .Net Framework 3.5 runtime 就是了!

(注:以上是查询网上高手资料整理,放在一块也好理解)

自动启动ASP.NET IIS 7.5 .NET4.0

.net web site 第一次启动慢
  • ronmy
  • ronmy
  • 2011年03月26日 18:34
  • 5646

64位win10系统无法安装.Net framework3.5的两种解决方法

近日有网友反映在windows10_64位系统电脑上安装Net framework3.5,操作时总失败,怎么办呢?小编下面就介绍win10 64位系统无法安装Net framework3.5的两种解决...
  • zang141588761
  • zang141588761
  • 2016年08月10日 23:30
  • 198324

IIS运行.NET4.0配置

IIS运行.NET4.0配置 本文转自http://hi.baidu.com/linzongmao/item/6a251b801c8aefceb071543c “/CRM”应用程序...
  • qinghecool
  • qinghecool
  • 2014年04月01日 15:59
  • 1597

win10下的net framework3.5 无法安装的解决

最近客户机升级新装的win10,在客户机上安装原先Net程序时,提示需要安装net framework3.5 ,现将遇到的问题的解决办法列举如下,希望能帮助到那些需要的人吧。以下内容部分取自各个论坛的...
  • changqiaozsl
  • changqiaozsl
  • 2016年03月09日 15:14
  • 24815

C#winform检测电脑安装的.netframework版本和是否安装了某软件

代码如下: //C#获取已安装 .NET Framework 版本 private static string[] GetDotNetVersions() ...
  • myesn
  • myesn
  • 2016年06月21日 22:49
  • 2290

win8离线和在线均无法安装.net framework 3.5 问题解决方案

1  Win8/8.1无法安装.net framework3.5的解决方法    Win8/8.1默认安装的是net framework4.5,没有net framework3.5(安装sql200...
  • qingmoxinyu
  • qingmoxinyu
  • 2014年06月06日 08:45
  • 3843

无法安装net framework 3.5 的解决方法

电脑刚重装了Windows8.1系统,然后安装数据库的时候,却出现了这样的问题:您的电脑上的应用需要使用以下windows功能。          问题原因是:在安装系统的时候,NET Framew...
  • u013034640
  • u013034640
  • 2015年07月27日 17:36
  • 3578

Win10离线安装.NET Framework 3.5的方法技巧(附离线安装包下载)

在Windows10中,当我们安装某些软件的时候会提示“你的电脑上的应用需要使用以下Windows功能:.NET Framework 3.5(包括.NET 2.0和3.0)”。 ...
  • Reserved_person
  • Reserved_person
  • 2016年10月11日 14:28
  • 6987

【问题】.net framework 3.5安装教程

.net framework 3.5万能安装教程,Internet未连接
  • sds15732622190
  • sds15732622190
  • 2016年05月16日 17:06
  • 524

Windows 8/8.1下无法安装.Net Framework 3.5 的问题(自备ISO镜像)

Windows 8 各版本ISO镜像:(建议用迅雷或者QQ旋风离线下载) 32位简体中文: Windows 8 专业零售版:ed2k://|file|cn_windows_8_x86_dvd_9154...
  • maxsky
  • maxsky
  • 2013年01月06日 18:05
  • 12586
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:IIS安装前已经安装了.NET Framework,安装后如何启用.NETFramework
举报原因:
原因补充:

(最多只允许输入30个字)