HDU1082 Matrix Chain Multiplication 栈+字符串处理

1.题目描述:

Matrix Chain Multiplication

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1711    Accepted Submission(s): 1110


Problem Description
Matrix multiplication problem is a typical example of dynamical programming. 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500. 

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy. 
 

Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. 
The second part of the input file strictly adheres to the following syntax (given in EBNF): 

SecondPart = Line { Line } <EOF>
Line = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
 

Output
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses. 
 

Sample Input
  
  
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
 

Sample Output
  
  
0 0 0 error 10000 error 3500 15000 40500 47500 15125
 

Source
2.题意概述:给出矩阵表达式,要你计算矩阵相乘运算中一共有多少次乘法。

3.解题思路:可以用栈模拟存的是目前进行了几次乘法,其实括号完全不需要管,每次碰到右括号则栈弹出两个矩阵,做一下乘法再将结果push进去,结束以后取栈顶输出就行

4.AC代码:

#include <stdio.h>
#include <stack>
#include <string>
#include <iostream>
using namespace std;

struct matrix
{
	int a, b;
	matrix(int a = 0, int b = 0) : a(a), b(b) {};
}m[26];

stack<matrix> s;

int main()
{
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		string name;
		cin >> name;
		int id = name[0] - 'A';
		cin >> m[id].a >> m[id].b;
	}
	string str;
	while (cin >> str)
	{
		int len = str.length();
		int flag = 0;
		int ans = 0;
		for (int i = 0; i < len; i++)
		{
			if (isalpha(str[i]))
			{	
				int id = str[i] - 'A';
				s.push(m[id]);
			}
			else if (str[i] == ')')
			{
				matrix m2 = s.top();
				s.pop();
				matrix m1 = s.top();
				s.pop();
				if (m1.b != m2.a)
				{
					flag = 1;
					break;
				}
				ans += m1.a * m1.b * m2.b;
				s.push(matrix(m1.a, m2.b));	// new matrix
			}
		}
		if (flag)
			puts("error");
		else
			printf("%d\n", ans);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值