HDU 1082 Matrix Chain Multiplication(栈和map的使用)

Matrix multiplication problem is a typical example of dynamical programming. 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500. 

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy. 
 

Input
Input consists of two parts: a list of matrices and a list of expressions. The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. The second part of the input file strictly adheres to the following syntax (given in EBNF): SecondPart = Line { Line } <EOF> Line = Expression <CR> Expression = Matrix | "(" Expression Expression ")" Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
 

Output
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses. 
 

Sample Input
  
  
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
 

Sample Output
  
  
0 0 0 error 10000 error 3500 15000 40500 47500
//
//  main.cpp
//  HDU 1028
//
//  Created by 张嘉韬 on 16/7/30.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <stack>
#include <cmath>
#include <cstring>
#include <map>
//#include <string>
//#include <string.h>
using namespace std;

struct matrix
{
    long long  r;
    long long l;
}matrixs[40];

map <char,int> m;

int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int n;
    long long ans=0;
    string s;
    stack<matrix> solve;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        char tempc;
        long long tr,tl;
        cin>>tempc>>tr>>tl;
        matrixs[i].r=tr;
        matrixs[i].l=tl;
        m[tempc]=i;
    }
    
    while(cin>>s)
    {
        ans=0;
        int flag=1;
        long long len=s.length();
        if(len==1) {cout<<"0"<<endl; continue;}
        for(int i=0;i<len;i++)
        {
            if(s[i]=='(') continue;
            else if(s[i]==')')
            {
                long long r1,r2,l1,l2;
                r2=solve.top().r;
                l2=solve.top().l;
                solve.pop();
                r1=solve.top().r;
                l1=solve.top().l;
                solve.pop();
                //cout<<r1<<"*"<<l1<<" "<<r2<<"*"<<l2<<endl;
                if(l1!=r2) {cout<<"error"<<endl;flag=0;break;}
                ans+=r1*l1*l2;
                matrix temp;
                temp.r=r1;
                temp.l=l2;
                solve.push(temp);
            }
            else
            {
                solve.push(matrixs[m[s[i]]]);
            }
        }
        if(flag==1) cout<<ans<<endl;
    }
    return 0;
}

15125
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值