hdoj 2955 Robberies【对立事件+0-1背包】

15 篇文章 0 订阅

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18678    Accepted Submission(s): 6892


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2159  2844  1171  1231  1087 
 

Statistic |  Submit |  Discuss |  Note


代码:
//这一道题是逆向思维,找不被抓到的概率的最大值,大于给定的概率的不被抓到的值
//也就是它偷东西不被抓到的概率更大,这样会让偷更多的东西!
//如果正向思维考虑的话,被抓到的概率最小要求之前那么多次都没有被抓住,比较麻烦 
//所以要考虑对立面
//题目上说被抓住的概率小于p,那么我们可以求不被抓住的概率大于1-p,不让抓住比较好求
//每一步不被抓住都是在上一步没被抓住的前提下进行的,所以分布相乘原则,要进行相乘
//最终求在不被抓住的前提下偷得前的最大值,我们就从大往小找概率大于1-p的概率,找到就
//直接输出,这个就是满足条件的偷的最大钱数 
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define max(a,b) (a>b)?a:b 
#define INF 0x3f3f3f3f
using namespace std;
double p;
int n;
int a[105];
double b[105];
double dp[10005];
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int sum=0;
		scanf("%lf%d",&p,&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%lf",&a[i],&b[i]);
			b[i]=1-b[i];
			sum+=a[i];
		}
		memset(dp,INF,sizeof(dp));//求概率的最小值 
		dp[0]=1;//不偷的话不被抓到的概率为1 
		for(int i=0;i<n;i++)
		{
			for(int j=sum;j>=a[i];j--)
			{
				dp[j]=max(dp[j],dp[j-a[i]]*b[i]);//不被抓到的概率的最大值	
			}//对应的就是被抓到的概率就减到最小了,偷得钱就变多了! 
		}
		for(int i=sum;i>=0;i--)
		{
			if(dp[i]>=1-p)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值