Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
/*
0-1背包。这个。。。不解释了
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1008
int v[maxn],w[maxn];
int dp[maxn][maxn];
inline int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int t;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
int N,W;//有N种石头,背包总体积为W
scanf("%d%d",&N,&W);
for(int j=1;j<=N;j++)//我擦。scanf("%d%d",&v[j],&w[j]);我既然看了半小时才看出来~~~
{
scanf("%d",&v[j]);
}
for(int j=1;j<=N;j++)
{
scanf("%d",&w[j]);
}
memset(dp,0,sizeof(dp));
for(int j=1;j<=N;j++)
{
for(int k=0;k<=W;k++)
{
dp[j][k]=dp[j-1][k];//注意写成(int k=w[j];k<=W;k++){dp[j][k]=max(dp[j-1][k],dp[j-1][k-w[j]]+v[j])是错的
if(k>=w[j])
{
dp[j][k]=max(dp[j][k],dp[j-1][k-w[j]]+v[j]);
}
}
}
printf("%d\n",dp[N][W]);
}
return 0;
}
/*
不知道为什么的可以看这组数据
1
5 0
2 4 1 5 1
0 0 1 0 0
*/