杭电OJ题 1544 Palindromes解题报告

Palindromes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 912    Accepted Submission(s): 389



Problem Description
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

Now give you a string S, you should count how many palindromes in any consecutive substring of S.
 

Input
There are several test cases in the input. Each case contains a non-empty string which has no more than 5000 characters.

Proceed to the end of file.
 

Output
A single line with the number of palindrome substrings for each case.
 

Sample Input
  
  
aba aa
 

Sample Output
  
  
4 3
 
————————————————————————————————————————————————————————
可以通过压缩来减少对相同字符的字符串的处理,可用公式n*(n+1)/2来求count

/****************************
 *Name:Palindromes.c
 *Tags:ACM water
 *Note:可以通过压缩来减少对相同字符的字符串的处理,可用公式n*(n+1)/2来求count
 ****************************/

#include <stdio.h>
#include <string.h>

int main()
{
      int is_p;
      char str[5002], prostr[5002];
      int num[5002];
      int l, i, j, count, t, t1, t2;
      while(scanf("%s", str) != EOF) {
	    t = 0;
	    num[0] = 1;
	    prostr[0] = str[0];
	    for(i = 1; str[i]; i++) {
		  if(str[i] == str[i-1]) {
			num[t]++;
		  } else {
			t++;
			prostr[t] = str[i];
			num[t] = 1;
		  }
	    }	//压缩	
	    l = t+1;
	    count = 0;
	    for(i = 0; i < l; i++) {
		  count += num[i]*(num[i]+1)/2;
	    }
	    for(i = 0; i < l; i++) {
		  t1 = i-1;
		  t2 = i+1;
		  if(t1 < 0 || t2 >= l) {
			continue;
		  }
		  is_p = 0;
		  while(prostr[t1] == prostr[t2] && num[t1] == num[t2]) {
			count += num[t1];
			t1--;
			t2++;
			if(t1 < 0 || t2 >= l) {
			      is_p = 1;
			      break;
			}
		  }
		  if(is_p == 0 && prostr[t1] == prostr[t2]) {
			if(num[t1] < num[t2]) {
			      count += num[t1];
			} else {
			      count += num[t2];
			}
		  }
	    }
	    printf("%d\n", count);
      }
      return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
杭电oj是杭州电子科技大学开发的一个在线评测系统,主要用于计算机考研的教育辅助工具。对于计算机考研的学生来说,杭电oj提供了一个良好的平台,可以进行编程练习和算法训练,帮助学生提升编程能力和算法水平。 首先,杭电oj上有大量的目库,涵盖了计算机考研的各个方面,比如数据结构、算法设计、数据库等,学生可以根据自己的需要选择相应的目进行练习。目难度分级明确,从简单到困难,适合不同水平的学生进行练习。通过解题训练,学生可以熟悉各类算法思想和程序设计方法,提高解题能力。 其次,杭电oj提供了在线评测系统,可以帮助学生及时了解自己的编程能力和代码水平。在解答目后,杭电oj会自动评判答案的正确性和效率,以及输出格式是否正确。学生可以根据评测结果对自己的代码进行优化和改进,提高编程的正确性和效率。 此外,杭电oj还提供了讨论区功能,学生可以与其他考研学生进行交流和讨论。在讨论区里,学生可以提问、回答问,分享解题思路和经验,相互学习和进步。通过互助学习,学生可以更好地理解和掌握各类算法和编程知识,提高解题的能力和效率。 总的来说,杭电oj对于计算机考研的学生是一个非常有用的教育辅助工具,它提供了库、评测系统和讨论区,能够帮助学生提升编程能力和算法水平,提高解题能力和效率。对于计算机考研的学生来说,积极利用杭电oj进行练习和学习,能够有效地提高自己的竞争力和通过考研的概率。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值